
Reydisp Evolution 32
Software

V9.87

Manual

C53000-H7050-C032-1

Table of Contents

Introduction and Installation 1
Getting Started 2
Communications 3
Command Reference 4
Miscellaneous 5



ii NOTE
For your own safety, observe the warnings and safety instructions contained in this document, if available.

Disclaimer of Liability
Subject to changes and errors. The information given in
this document only contains general descriptions and/or
performance features which may not always specifically
reflect those described, or which may undergo modifica-
tion in the course of further development of the products.
The requested performance features are binding only when
they are expressly agreed upon in the concluded contract.
Document version: C53000-H7050-C032-1.00
Edition: 03.2023
Version of the product described: V9.87

Copyright
Copyright © Siemens 2023. All rights reserved.
The disclosure, duplication, distribution and editing of this
document, or utilization and communication of the content
are not permitted, unless authorized in writing. All rights,
including rights created by patent grant or registration of a
utility model or a design, are reserved.



Table of Contents

1 Introduction and Installation........................................................................................................................5
1.1 Introduction........................................................................................................................6
1.2 Installation..........................................................................................................................8

2 Getting Started........................................................................................................................................... 13
2.1 Using Reydisp Evolution.................................................................................................... 14
2.2 Main Window....................................................................................................................16
2.3 Manipulating Relay Settings.............................................................................................. 17
2.4 Settings Editor Window..................................................................................................... 18
2.5 Manipulating Relay Waveforms......................................................................................... 26
2.6 Data Header Window........................................................................................................ 27
2.7 Data Window Menu.......................................................................................................... 31
2.8 Event Display.................................................................................................................... 32
2.9 Event Window...................................................................................................................33
2.10 Fault Display..................................................................................................................... 35
2.11 Fault Window....................................................................................................................36
2.12 Instrument Window.......................................................................................................... 37
2.13 Edit Window..................................................................................................................... 39
2.14 Teletype Window.............................................................................................................. 40
2.15 General Command Window...............................................................................................41
2.16 Spontaneous Messages Window........................................................................................42
2.17 Spontaneous Messages Window Measurands.................................................................... 43
2.18 Spontaneous Messages Window Event Log........................................................................44
2.19 Spontaneous Messages Window Data Point Monitor.......................................................... 48
2.20 File Manager Window....................................................................................................... 49
2.21 Data Log Window..............................................................................................................53

3 Communications.........................................................................................................................................55
3.1 Configure Communications...............................................................................................56
3.2 Communications Tutorial.................................................................................................. 62
3.3 Advanced Communications Options.................................................................................. 65

4 Command Reference.................................................................................................................................. 67
4.1 File Menu..........................................................................................................................68
4.2 Edit Menu......................................................................................................................... 76
4.3 View Menu....................................................................................................................... 80
4.4 Relay Menu.......................................................................................................................94
4.5 Options Menu................................................................................................................. 122

Reydisp Evolution 32, Software, Manual 3
C53000-H7050-C032-1, Edition 03.2023



4.6 Window Menu................................................................................................................ 127
4.7 Help Menu......................................................................................................................129

5 Miscellaneous...........................................................................................................................................133
5.1 System Information.........................................................................................................134
5.2 Action On Dialogue......................................................................................................... 135
5.3 Save Real Values Dialogue............................................................................................... 136
5.4 Select Setting List............................................................................................................137
5.5 Select Which Item........................................................................................................... 138
5.6 Rename.......................................................................................................................... 139
5.7 Select Viewer.................................................................................................................. 140
5.8 Select Record.................................................................................................................. 141
5.9 RS232 Cable Wiring.........................................................................................................142
5.10 Command Line Parameters..............................................................................................143
5.11 Comtrade Export Dialogue.............................................................................................. 145
5.12 Create Signals Wizard......................................................................................................146
5.13 Save Settings As XML...................................................................................................... 152

Table of Contents

4 Reydisp Evolution 32, Software, Manual
C53000-H7050-C032-1, Edition 03.2023



Introduction and Installation

1.1 Introduction 6
1.2 Installation 8

1

Reydisp Evolution 32, Software, Manual 5
C53000-H7050-C032-1, Edition 03.2023



Introduction
Reydisp Evolution is Microsoft Windows based support software for the Reyrolle brand of protection devices
incorporating the Informative Communications Interface.
The following features are provided:

• Data download
– Settings
– Events including spontaneous events
– Waveforms
– Faults
– Instruments
– System information
– Data directory (Waveform storage times)
– Device's built in help

• Settings manipulation
– Edit settings
– Upload settings
– Store and retrieve settings
– Get and switch active settings group
– List settings group in English
– Compare settings

• Waveform manipulations
– View waveforms with values and timings
– Zoom functions
– Sample points only
– User defined tabbed views
– Configurable waveform display
– Analysis functions

• Device control
– Login/Logout
– Trigger & reset waveforms
– Reset events
– Reset flags
– Close output relay
– Set device time
– Map networked devices
– Direct command teletype interface
– Automatic polling of devices

1.1
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• Communication features
– Direct RS232 connection
– Connection via USB to suitable devices
– TCP/IP connection

• Usability features
– Save to & reload from disk
– Printing
– Windows clipboard functions
– Configurable button bar
– Configurable confirmation safety options

Introduction and Installation
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Installation
Reydisp Evolution is supplied as a self extracting installer. On running this file the Figure 1-1 dialog box
appears.
The user should click setup to begin the installation.

[sc_ReydispEvolution_SetupWelcome, 1, --_--]

Figure 1-1 Reydisp Evolution Setup Wizard

If you have the USB cable connected to a relay, you will be reminded to disconnect it before continuing, as
shown in Figure 1-2, before the dialog Figure 1-1 is shown.

[sc_ReydispEvolution_USBConnectionTest, 1, --_--]

Figure 1-2 USB Connection Test

The disclaimer dialog box appears; after reading the disclaimer, the user should check I accept… then click the
Next button to continue.

1.2
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[sc_ReydispEvolution_License, 1, --_--]

Figure 1-3 Reydisp Evolution License Agreement

The choose components dialog box appears; the user should select which components to install. Note the USB
driver is compulsory, then the user can click the Next button to continue.

[sc_ReydispEvolution_Components, 1, --_--]

Figure 1-4 Choose Components

The user can then select the target location drive and destination directory for the application and click Next
to continue.

Introduction and Installation
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[sc_ReydispEvolution_InstallLocation, 1, --_--]

Figure 1-5 Install Location

The user should then select whether to install for a single user or everyone who uses the PC and click Install to
begin the installation.

[sc_ReydispEvolution_Users, 1, --_--]

Figure 1-6 Choose Users

The progress dialog will be displayed.

Introduction and Installation
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[sc_ReydispEvolution_Installing, 1, --_--]

Figure 1-7 Reydisp Evolution Installing

During the installation the user will be asked to install the USB driver.

[sc_ReydispEvolution_DriverSecurity, 1, --_--]

Figure 1-8 USB Device Driver Software

When this dialog box appears the user needs to confirm installation of a driver. The driver is a USB driver for
use with the devices that have a USB port on their fascia.
The user can click Install to install the driver.
At this point if everything has installed correctly the confirmation dialog as shown in Figure 1-9 will be
displayed.
The user can then click Finish to complete the installation. If the Run box on the Figure 1-9 is checked Reydisp
will now start.

Introduction and Installation
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[sc_ReydispEvolution_Installed, 1, --_--]

Figure 1-9 Reydisp Evolution Installation Completed
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Using Reydisp Evolution
This section gives a brief tutorial on using Reydisp Evolution.
Reydisp Evolution can be used without being connected to a device. Some example (template) files of data
and settings are supplied with the product to demonstrate its use. This description will make use of those
files in the following examples. There will be some references to working with devices online, although, the
majority of information regarding this subject will be given in the 3 Communications section which describes
connecting to a device.
In the following text when a menu command is described the notation Menu > Command or Menu > Sub
Menu > Command will be used, for example, select Open from the File menu would be shown as File >
Open.
When running Reydisp the help system can be used to get more information, for example, to get help about
the active data window select Help > Help for Active Window or press F1.

If Reydisp Evolution is not running start it by double clicking on its icon.
Reydisp Evolution can be used in both English Language or Turkish Language. To change the language select
the File menu and User Interface Language.

[sc_ReydispEvolution_UserInterfaceLanguage, 1, --_--]

Figure 2-1 User Interface Language

A popup menu allows the selection between English (UK) and Turk.

2.1
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[sc_ReydispEvolution_UserInterfaceLanguagePopup, 1, --_--]

Figure 2-2 User Interface Language Popup

After selection the user interface language will change to display menus and messages in the chosen
language.

[sc_ReydispEvolution_UserInterfaceLanguageTurk, 1, --_--]

Figure 2-3 User Interface Language Turkish

Getting Started
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Main Window

[sc_ReydispEvolution_MainWindow, 1, en_US]

Figure 2-4 Main Window

The main display of Reydisp Evolution uses the standard Microsoft Multiple Document Interface (MDI) format.
A menu bar (File, Edit … Help) near the top of the window lists the commands.
These commands are duplicated on a configurable button bar beneath the menu bar, as shown in Figure 2-5.
A description of a button can be seen by moving the mouse pointer over the button to display a hint.

[sc_ReydispEvolution_MenuBar, 1, --_--]

Figure 2-5 Menu Bar

At the bottom of the window is a status bar, illustrated in Figure 2-6, containing status and connection
information. A green tick signifies connected and a red cross is disconnected. The connection information
describes the address of the device and the type of connection, for example a COM port or TCP/IP connection.

[sc_ReydispEvolution_StatusBar, 1, --_--]

Figure 2-6 Status Bar

2.2
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Manipulating Relay Settings
Opening an Example

The user can select File > New From Template. A dialog box, shown in Figure 2-7, is displayed listing the
template files installed.

[sc_ReydispEvolution_OpenTemplate, 1, en_US]

Figure 2-7 Open Template

The user can then select the Settings tab and then a template from the list and click OK. The Setting Editor is
displayed.

2.3
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Settings Editor Window
A settings editor window is used to manipulate settings. Reydisp Evolution can display several Settings Editor
windows. This window allows settings to be downloaded from a device, changed, and uploaded to the device.
Settings can also be saved to and reloaded from disk.
The settings editor shows an explorer style view with a menu tree on the left and a settings list on the right.
The System tab at the top left of the settings editor window displays information about the device which
saved the settings.
The Notes tab holds text which can be used to describe the settings within the file.
The Config tab is a shortcut page that lists settings which enable or disable elements.
The Settings tab displays the settings in a tree format.
The Matrix tabs, Input, Output, and LED, show the settings relating to respectively Status Inputs, Output
Relays and LEDs in matrix displays; followed by any Quick Views that have been defined; these settings are
also shown in standard format on the tree display.

Changing Settings
Click the Settings tab to make it active. There are different methods to change settings depending on the type
of setting. To change a setting the user should select it in the list. The appropriate editor is then displayed or a
button to open an editor.

[sc_ReydispEvolution_SettingsEditor, 1, en_US]

Figure 2-8 Settings Editor

Selectable Settings
If the setting is a list of pre-defined options, a drop down list is shown when the setting is selected. The user
should choose the value required from this list.

2.4
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[sc_ReydispEvolution_SettingsEditorDropdown, 1, en_US]

Figure 2-9 Settings Editor Dropdown

Text Settings
A text setting, for example, a Relay Identifier or User ID/Password, the text editor will be displayed; the user
can type the text required then press return.

ii NOTE
The characters that can be used are shown in the status bar at the bottom of the window.

[sc_ReydispEvolution_SettingsEditorTextBox, 1, en_US]

Figure 2-10 Settings Editor Text Box

Some settings are edited as special strings and only allow certain characters. An example is Settings
Group Select. On a device with 5 status inputs this setting will have 5 characters. The first (left) character
represents status input 1 and the last (right) character the last status input (in this example input 5). To

Getting Started
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activate group 2 using input 1 enter 2 as the first character. Status inputs which are not to be used to set
groups should be assigned the underscore character, for example 2 _ _ _ _. To make status input 1 activate
setting group 3, input 3 activate group 5 and input 4 activate group 2, enter 3 _ 5 2 _.

[sc_ReydispEvolution_SettingsGroupSelect, 1, en_US]

Figure 2-11 Settings Group Select

Bit Selection Strings
For bit selection settings a button is displayed next to the setting. The user should click it, or double click the
setting, to open the bitwise editor. After changing the values click OK to store.

[sc_ReydispEvolution_BitSelectionSettings, 1, en_US]

Figure 2-12 Bit Selection Strings

Using the Matrix Editor
To use a matrix editor the user should click the appropriate tab to make it active. A subset of settings is listed
in the left pane and the controlled object across the top of the right pane. The user can click in the box at the

Getting Started
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intersection between the two to select or deselect a point. Figure 2-13 shows part of a matrix, in it LED (L) 1
will operate by Phase A, L2 by Phase B and L3 by Phase C.

[sc_ReydispEvolution_MatrixEditor, 1, en_US]

Figure 2-13 Matrix Editor

Help Hints
Help hints are displayed, when the user hovers over a setting, describing each setting, as illustrated in
Figure 2-14 and Figure 2-15.

[sc_ReydispEvolution_HelpHintsExample1, 1, --_--]

Figure 2-14 Help Hints Example 1

Getting Started
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[sc_ReydispEvolution_HelpHintsExample2, 1, --_--]

Figure 2-15 Help Hints Example 2

The hints can be turned on or off from the context menu by clicking the right mouse button while on the
settings display, illustrated in Figure 2-16.

[sc_ReydispEvolution_ShowHelpHints, 1, --_--]

Figure 2-16 Show Help Hints

Using the Config Editor
To use the config editor the user should click the appropriate tab to make it active. A subset of settings is listed
that control whether elements are enabled or disabled. The user can check the box to the left of the setting to
enable or disable it.

Getting Started
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[sc_ReydispEvolution_ConfigEditor, 1, en_US]

Figure 2-17 Config Editor

Quick Settings Pages
Some devices have had quick settings pages defined for them, which contain a subset of related settings.
These pages are displayed as additional tabs to the right of the matrix views. Settings are changed using the
standard windows style controls.

ii NOTE
The controls for settings that are related to others may be disabled until other settings are changed, as
illustrated in Figure 2-18.

Figure 2-18 shows the 51-1 Element settings are unavailable until its checkbox is checked. Contrast this with
the 51-2 Element settings which are available. In the Measured E/F group no settings are available because the
whole function is disabled.
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[sc_ReydispEvolution_QuickSettingsPages, 1, --_--]

Figure 2-18 Quick Settings Pages

Once changed, settings from this page can be sent to the device relay using the using the update button

 and Group control at the top left corner of the page. If the setting were loaded from a file, rather
than directly from a device, the group box will initially be empty. Alternatively, the standard commands Relay
> Settings > Update Changed Settings and Relay > Settings > Send All Settings can be used to update all
settings or all changed settings across the tabs.

Saving, Opening, and Exporting Settings
The settings can be saved by using File > Save, or to save the file under a new name use the File > Save As
command. Before using either of these commands, ensure the settings window is active (topmost). Settings
can be saved in the original settings format (.set) or the new format (.rsf2) which holds more information and
is more secure. To save the contents of the Notes tab the user should use the new format. Settings that are
saved in either of these formats can be reloaded using the File > Open command.
To export settings in CSV, XML , TXT or RTF formats use the File > Save As command and select the type of file
required from the Save File as Type list. CSV and TXT files are files that can be opened in another application,
for example, CSV in the Excel spreadsheet or TXT in Notepad. XML files contain a list of the settings and their
descriptive information. RTF files are a table of the settings containing their present value, default value and
space for a user value, and can be opened in a suitable word processor, as illustrated in Figure 2-19.
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[sc_ReydispEvolution_ExportedSettingsExample, 1, --_--]

Figure 2-19 Exported Settings Example

Getting Settings from and Uploading them to a Device
To upload settings the user should use the Relay > Settings > Update Changed Settings and Relay >
Settings > Send All Settings commands.
Getting settings from a device is the online equivalent of opening a file. To get the settings use the Relay >
Settings > Get Settings command.

Printing Settings
Settings files can be printed using the command File > Print.

Configuring the Display
To change the default colours of the display and the general options use Options > Evolution . Refer to
Evolution, Page 123 for a description of the options.
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Manipulating Relay Waveforms
Opening an Example

Select File > New From Template. Select the Data tab and then the template DU3-22OxC from the list and
click OK. The Data Header window will open.

2.5
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Data Header Window

[sc_ReydispEvolution_DataHeaderWindow, 1, en_US]

Figure 2-20 Data Header Window

The waveform display window will open as illustrated in Figure 2-20.
Initially for each type of device there are default views defined containing the Analogue Channels, Digital
Channels and All Channels. Users can create new views or modify existing views, edit the analogue channel
information, and format the display using the View > Properties command.
A view has 2 vertical cursors (left and right), and a dashed dotted line showing the trigger point. In the
status bar at the bottom of the window is the time of the position at each cursor, and centrally the difference
between the times, as illustrated in Figure 2-21.

[sc_ReydispEvolution_DataHeaderTimes, 1, --_--]

Figure 2-21 Data Header Times

Up to 5 signals can be displayed on each graph, one of which can be a digital signal. Each graph in a view has
a channel label followed by the magnitude of the sample point at the left cursor at its left, and the magnitude
of the point at the right cursor to its right. When multiple signals are displayed on a graph this information
is repeated for each signal. When single signals are displayed the maximum and minimum magnitudes of the
displayed data are also shown at the right.
On digital signals the magnitude is shown as 1 (high) and 0 (low). In this edition of Reydisp digital signals are
drawn as a single line for low and a coloured block for high as illustrated in Figure 2-22.

[sc_ReydispEvolution_DataHeaderDigitalSignal, 1, --_--]

Figure 2-22 Data Header Digital Signal

Up to 5 Analogue signals can be drawn on an axis, as shown in Figure 2-23.

2.6
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[sc_ReydispEvolution_DataHeaderAnalogueSignalAxis, 1, --_--]

Figure 2-23 Analogue Signals on Axis

One Digital signal can be drawn with up to 4 Analogue signals on an axis, as shown in the expanded example
Figure 2-24.

[sc_ReydispEvolution_DataHeaderDigitalSignalAxis, 1, --_--]

Figure 2-24 Digital and Analogue Signals on Axis

Cursors
To move the cursors, the user must ensure the window is active by clicking in it with the mouse. The mouse
pointer can be moved over one of the cursors, and the cursor shape will change. When over the left cursor it
will show ← and when over the right →. If the user was to click and hold the left mouse button, the cursor
changes again to the move cursor ↔. While holding down the left mouse button the user can drag the cursor
to a new position. Notice the changes in the times and magnitudes. The mouse button van be released when
the cursor is in its new position.

ii NOTE
The left and right cursors cannot cross, if one cursor is in the way of the other, move the other cursor first.

Smaller movements can be made by using the keyboards cursor keys (← →). The cursor to move is selected
by the View > Activate Left / Right Cursor command. The cursor that is active for keyboard control is shown
with a mark at its top. The last cursor moved with the mouse will be active for keyboard control.

Zoom
The data in the window can be expanded horizontally with the zoom function. The zoom function uses the
cursors to mark the extremities. Select View > Zoom In to magnify the data between the cursors. View >
Zoom Out reduces magnification slightly. View > Show Full removes any magnification. When a view is
zoomed horizontally a scrollbar at the bottom of the screen allows movement of the waveform horizontally.

Getting Started
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[sc_ReydispEvolution_DataHeaderZoomScrollbar, 1, --_--]

Figure 2-25 Zoomed Scrollbar

View windows can be expanded vertically with the command View > Vertical Zoom In. The expansion can be
reduced with the View > Vertical Zoom Out command. There is a maximum limit on a vertical zoom.

View Highlighted Sample Points
Analogue waveforms can be displayed as with the sample points highlighted. View > Highlight Samples
toggles highlighting on or off.

[sc_ReydispEvolution_DataHeaderSamplePoints, 1, --_--]

Figure 2-26 Highlighted Sample Points

Additional Tabs
The waveform display also contains tabs holding information about the device on the System tab, the
COMTRADE configuration on the Config tab, the COMTRADE inf file on the INF tab and some text notes
which correspond to the COMTRADE HDR file on the Notes tab. The information on the Notes and INF tabs is
editable by the user.

Saving, Opening, and Exporting Data
Waveforms are by default saved in the private Reyrolle file format RDF2. They can also be saved in the original
Reydisp format (DAT) with some loss of information, or COMTRADE 1991 and 1999 formats. These types of
files can be reopened in Reydisp using the File > Open command. The data is saved by using File > Save, or
to save the file under a new name use the File > Save As command. Before using either of these commands,
ensure the settings window is active (topmost).

Getting Started
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Reydisp can export data as DADiSP or Text (Real Values) format; these files cannot be reopened by Reydisp.
To export use the File > Save As command, selecting the type of file required from the Save as type list, as
shown in Figure 2-27.

[sc_ReydispEvolution_DataHeaderSaveAs, 1, --_--]

Figure 2-27 Save As

When saving the Data Values as Real Values (ASCII text) an options dialog box is displayed allowing the user to
choose which items to include. Another options box is displayed when exporting COMTRADE.

Getting Data from a Device
Getting data from a device is the online equivalent of opening a file. To get the settings use the Relay >
Waveform > Get Waveform Record command.

Printing Waveforms
Waveforms can be printed using the command File > Print. When printing waveforms some additional
information can be added to the page. The Print Options dialog box is displayed prior to printing or it can be
opened with the File > Print Options command.

Data Window Menu
A shortcut menu of useful commands is displayed when the user right clicks on a waveform window.

Getting Started
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Data Window Menu

[sc_ReydispEvolution_DataWindowMenu, 1, en_US]

Figure 2-28 Data Window Menu

This popup menu appears when the right mouse button is clicked on a graphical data view. It is a shortcut
menu which duplicates commands from the main menus, and allows setting the cursors directly.
Set Left Cursor and Set Right Cursor allow setting the cursor to the position of the mouse pointer on a
waveform signal display. Right click the mouse at the point to set the cursor and select one of these options
from the menu.

ii NOTE
The user is unable to cross the cursors therefore they may only have one option at the point they select. In
this instance, and also if the cursors are off the screen the user may have to set one cursor first and then
the other.

Absolute Time toggles time mode between Relative Time (time relative to the origin), and absolute Year/
Month/Day, Hours, Minutes and Seconds.

2.7
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Event Display
Opening an Example

To open an example the user should select File > New From Template. Then, select the Data tab and then
the template AG1-402-Events from the list and click OK.

2.8
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Event Window

[sc_ReydispEvolution_EventRecords, 1, en_US]

Figure 2-29 Event Records

The event display consists of 2 tabs, a System tab with information about the source device and an Event
Record tab with a list of events. Each event is on a separate line. Events are grouped into blocks of events
with the same time stamp. The first line in a block has the time stamp, followed by the event information,
subsequent lines in the block only have the event information. The event information consists of an event
type, an action and a description.
Definitions
Time format HH:MM:SS.SSSS
Date format dd/mm/yy
Event Type
IEC IEC defined event
Rey Reyrolle privately defined event

Action
There are 2 kinds of events, 1 and 2 stage. 1 stage events occur to signify an event has happened, for
example, the Start/Restart of the device. 2 stage events signify a binary event has changed state. An example
of this type would be when a starter picks-up (raised) and sometime later drops-off (cleared). In summary, a 1
stage event is Raised only, a 2 stage event maybe Raised or Cleared.

Description
The Event described in English.

Delta Time
If 2 events in the list are selected the time difference between them is displayed in the status bar at the
bottom of the Event window. This information can also be displayed using the Relay > Events > Events Time
Difference function.

Saving and Opening Events
Events are saved in a text file that can be opened in a normal text editor, or if not changed reopened in
Reydisp using the File > Open command. The data is saved by using File > Save, or to save the file under
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a new name use the File > Save As command. Before using either of these commands, ensure the events
window is active (topmost).

Getting Events from a Device
Getting events from a device is the online equivalent of opening a file. To get the events use the Relay >
Events > Get Events command.

Printing Events
Events can be printed using the command File > Print.
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Fault Display
Opening an Example

Select File > New From Template. Select the Data tab and then the template GAF-Faults from the list and
click OK.
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Fault Window

[sc_ReydispEvolution_FaultWindow, 1, --_--]

Figure 2-30 Fault Window

The fault display consists of a list with information about the source device at the top followed by the faults;
see Figure 2-30. Each fault is a textual description on a separate line.

Saving and Opening Faults
Faults are saved in a text file, that can be opened in a standard text editor, or reopened in Reydisp using the
File > Open command. The data is saved by using File > Save, or to save the file under a new name use
the File > Save As command. Before using either of these commands, ensure the faults window is active
(topmost).

Getting Faults from a Device
Getting faults from a device is the online equivalent of opening a file. To get the faults use the Relay > Data
Record > Get Data Record command.

Printing Events
Faults can be printed using the command File > Print.

2.11
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Instrument Window
The Instrument window displays a real time list of instruments from a device. This function requires the device
to be online.

[sc_ReydispEvolution_InstrumentsAvailableTab, 1, en_US]

Figure 2-31 Available Tab

There are 3 tabs at the top of the instruments window. Use the Available tab, Figure 2-31, to show the list of
instruments that can be monitored on a particular device. Each instrument in the list has a checkbox next to it
that must be checked for the instrument to be polled.

[sc_ReydispEvolution_InstrumentsActiveTab, 1, en_US]

Figure 2-32 Active Tab
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The selected instruments are displayed in the list on the Active tab. The instruments are polled from top to
bottom of the list. The more instruments selected the slower the polling time. Instruments will only be polled
when the Active tab is selected.
The instrument lists can be sorted be clicking on the column headings. The sort is alphabetic by instrument
name or units when clicking respectively the Instrument or Unit columns. Clicking on the Value (or #) column
will sort the instrument by their logical identification number, which is how the available list is initially
displayed.
The System tab displays information about the device.
Several instrument windows can be opened simultaneously to poll different device addresses. When opened
the instrument window polls the current address. Therefore before opening an instrument window set the
address using the Relay > Set Address > Address or Relay > Set Address > Device Map commands.

Saving Instruments
The present content of the instrument window can be saved using the File > Save or to save the file under
a new name use the File > Save As command. Instruments are saved as text files which can be reopened in
a text editor, or as a text file in Reydisp. Before using either of these commands, ensure the faults window is
active (topmost).

Getting Faults from a Device
Getting instruments from a device is the online equivalent of opening a file. To open the instruments use the
Relay > Information > Monitor Instruments command.

Printing Instruments
Instruments can be printed using the command File > Print.
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Edit Window

[sc_ReydispEvolution_EditWindow, 1, --_--]

Figure 2-33 Edit Window

The Edit window is used to display and edit a text file or a text response from a relay.
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Teletype Window

[sc_ReydispEvolution_TeletypeWindow, 1, --_--]

Figure 2-34 Teletype Window

The Teletype window allows commands to be sent to the devices and displays the responses as text or in
hexadecimal notation. Type a command, for example HELP, into the control and click Send. If the response
should be displayed in hexadecimal format check the Hex Mode box before clicking the Send button. The
commands are those displayed by the online help function.
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General Command Window

[sc_ReydispEvolution_GeneralCommandWindow, 1, en_US]

Figure 2-35 General Command Window

This is an interface for the user to perform an IEC 60870-5-103 style General Command from within Reydisp
Evolution. The response to this command is displayed in the Spontaneous Messages window with a cause of
transmission either C/A (Command Acknowledgement) or NCA (Negative Command Acknowledgement).
A list of general commands for the connected device is displayed. Select a command from the list and press
the appropriate command button. Some commands are binary, in which case both the On/Execute and
Off buttons are available. Others are single state and only the On/Execute button is available. The General
Commands window can be kept open while other windows are activated.
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Spontaneous Messages Window
Reydisp contains a Spontaneous Events (or Messages) Window where data sent by the device during a
communications transaction but not explicitly requested by the user, is placed. This window is initially mini-
mized at the bottom of the main window. To monitor devices constantly ensure Auto Poll Mode is switched
on.

[sc_ReydispEvolution_SpontaneousEventWindow, 1, --_--]

Figure 2-36 Spontaneous Event Window

Open this window at any time to examine these events.

[sc_ReydispEvolution_SpontaneousEventWindowTabs, 1, en_US]

Figure 2-37 Spontaneous Event Window Tabs

The Spontaneous Events window display consists of 3 tabs:

• Measurands

• Event Log

• Data Point Monitor
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Spontaneous Messages Window Measurands

[sc_ReydispEvolution_SpontaneousEventWindowMeasurands, 1, en_US]

Figure 2-38 Spontaneous Messages Window Measurands

This display shows a table listing the IEC 60870-5-103 measurands being monitored. Each row has the time of
the measurand, its source address, and a list of the values it contains. The row will be updated when a new
measurand of the same type from the same source is received. Each value is displayed as a percentage of the
maximum that can be sent. Refer to the device documentation or settings for further information.
The descriptions used are stored in the ReyMeas.ini file in the program settings folder. The format used is an
INI file where the Function Type (FUN) number is the section heading and the Information number is the item
key, for example with FUN = 182 and INF =148:
[182]148=Ia,Ib,Ic,Va,Vb,Vc,P,Q,F
Reydisp can automatically calculate the values if it knows the scaling factors, either 1.2 or 2.4 times nominal,
of the measurands. This information can be added to the description of the measurand, in round braces after
the measurand name, as shown in the following example:
[182]148=Ia(1.2),Ib(1.2),Ic(1.2),Va(2.4),Vb(2.4),Vc(2.4),P,Q, F
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Spontaneous Messages Window Event Log

[sc_ReydispEvolution_SpontaneousEventWindowEventLog, 1, en_US]

Figure 2-39 Event Log Tab

The event time difference function is available on the Event Log.
If there is no communication taking place devices can be monitored for spontaneous events in the background
by toggling Relay > Control > Auto Poll on. Reydisp will poll the active nodes returned by the device map.
Clear the contents of the spontaneous event window with Relay > Events > Clear Spontaneous Events
Window, this doesn't affect the device.
The events can either be sorted by the event time, or when they arrive (which is faster) by changing the
setting accessed through Options > Evolution.

Display Format
The events are displayed in the following format:
<Time><Address><Protection><Action><Event Specific Information><Description>
These fields are described in the following table:
Field Description
Time The time stamp of the event in the format HH:MM:SS.SSS. If the event does not have a

time stamp a description of the type of event e.g. identification is displayed.
Address The address of the device that sent the event.
Protection A description of the type of protection device that generated the event, for example:

Mnemonic Description
OC-IEC870 IEC defined overcurrent event
OC-Reyrolle Reyrolle defined overcurrent event
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Field Description
Action Can be one of 5 states

State Description
Travelling A double point event is between states.
Cleared The event is cleared or off.
Raised The event is raised or on.
Invalid The event state is invalid, i.e. marked as both raised and

cleared.
Unknown The event returned a code that cannot be decoded.

Event Specific Infor-
mation

Additional information depending on the type of event

Format for Time Tagged Event
[<COT><Invalid Time><Summer Time><Supplementary Information><Relative
Time><FaultNumber>]
COT (Cause of Trans-
mission)

SpE Spontaneous event
Cyc Cyclic
FCB Reset frame count bit
RCU Reset communications unit
S/R Start/Restart
Pow Power on
T/M Test mode
T/S Time synchronize
GI General interrogation
TGI Termination of general inter-

rogation
L/O Local operation
R/O Remote operation
C/A Command acknowledgement
NCA Negative command acknowl-

edgement
TDD Transmission of disturbance

data
CAP Generic write command with

acknowledgement positive
CAN Generic write command with

acknowledgement negative
RCV Generic read command data

valid
RCI Generic read command data

invalid
GWC Generic write confirmation
nnn Unknown value

Invalid Time The flag to indicate whether the time of the event may be
invalid. Show IV when time may be invalid, or -- if time is valid.
The time would become invalid if the clock had not been set for
over 23 hours.

Summer Time The flag to indicate whether the summer time bit of the event is
set. This is used to indicate daylight saving is active. Shows SU
when the Daylight Saving Flag is set, otherwise --.
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Field Description
Supplementary
Information

Used when the COT is GI to show the scan number, otherwise 0.

Relative Time The Relative Time in milliseconds, if available, since the start of
the fault.

Fault Number Shows the fault number if available.
E.g. 1 No Relative Time and Fault Numbers Available
[GI -- SU SI=246 RT=----- F#=-----]
E.g. 2 Relative Time and Fault Numbers Available
[GI IV -- SI=246 RT= 0 F#= 0]

Format for Identification Event
[<COT><Compatibility Level><Manufacturer Name>[<Revision Numbers>]]
COT Cause of transmission, as described previously.
Compatibility Level 2 = No generic services, 3 = Supports generic services
Manufacturer Name Manufacturer specific text
Revision Numbers Manufacturer specific numbers

E.g. [RCU CL= 2 REYROLLE [ 0 0 0 0]]
Format for Time Synchronization Event
[<COT><Invalid Time><Summer Time><Day of Week><Date>]
COT Cause of transmission, as described previously.
Invalid Time As described previously
Summer Time As described previously
Day of Week Monday, Tuesday, etc. Day Not Set if not available.
Date Date in dd/mm/yy format.

E.g. [T/S -- -- Day Not Set 04/08/99]
Format for Terminate General Interrogation Event
[<COT><Supplementary Information>]
COT Cause of transmission, always TGI
Supplementary
Information

This value should be the same as those in the events with COT
GI. In this message it indicates that the GI sequence with this
number has completed.
E.g. [TGI SI=246 ]

Description Describes the event

Further Examples
Identification Ad= 1 OC

IEC870
Raised [RCU CL=2 REYROLLE [0000]] Reset CU

Identification Ad= 1 OC
IEC870

Raised [FCB CL=2 REYROLLE [0000]] Reset FCB

15:44:04.000 Ad= 1 Global Raised [T/S ---- Day Not Set 04/08/99] Time Synchro-
nization

15:45:17.040 Ad= 1 OC
IEC870

Raised [L/O ---- SI=0 --=----- --=-----] Settings
changed

15:45:17.090 Ad= 1 OC
IEC870

Cleared [L/O ---- SI=0 --=----- --=-----] Settings
changed

15:45:39.660 Ad= 1 OC
IEC870

Cleared [GI ---- SI=246 --=----- --=-----] Trip Test

15:45:39.765 Ad= 1 OC
IEC870

Cleared [GI ---- SI=246 RT=0 F#= 0] General starter
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Further Examples
15:45:40.025 Ad= 1 OC

Reyrolle
Cleared [GI ---- SI=246 RT=0 F#= 0] SEF/REF starter

15:45:40.275 Ad= 1 OC
IEC870

Cleared [GI ---- SI=246 RT=0 F#= 0] A-starter

15:45:40.560 Ad= 1 OC
IEC870

Cleared [GI ---- SI=246 RT=0 F#= 0] B-starter

15:45:40.785 Ad= 1 OC
IEC870

Cleared [GI ---- SI=246 RT=0 F#= 0] C-starter

15:45:41.035 Ad= 1 OC
IEC870

Cleared [GI ---- SI=246 RT=0 F#= 0] E-starter

GI Termination Ad= 1 Global Raised [TGI SI=246] GI Termination
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Spontaneous Messages Window Data Point Monitor

[sc_ReydispEvolution_SpontaneousEventWindowDataPointWindow, 1, en_US]

Figure 2-40 Spontaneous Messages Window Data Point Monitor

This display shows a table listing the present state of the data points (events) being monitored. Each row
contains an icon depicting the present state, the last time a point was updated, its source address, a descrip-
tion, and any additional information sent. The row will be updated when a new data point of the same type
from the same source is received.

Table 2-1 Icons

(Blank) No binary state to display.
(Green) The data point is cleared.

(Red) The data point is raised.

(Blue) The data point is travelling between states.

(Black) The data point is in error, both raised and
cleared signalled.
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File Manager Window

ii NOTE
The file manager has been disabled in the standard release of Reydisp.

! WARNING
Using file manager should only be used with extreme caution.

² Modification or deletion of files can cause the device to cease to operate as expected.

Some devices have file management facilities. This window allows manipulation of the files within the device.

[sc_ReydispEvolution_FileManagerFolders, 1, --_--]

Figure 2-41 File Manager Folders

Initially a list of folders is displayed, shown in Figure 2-41. A menu is available by right clicking on the window
to format the display. Double click on a folder or select a folder and press the view button to display its
contents, shown in Figure 2-42.
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[sc_ReydispEvolution_FileManagerFoldersContents, 1, --_--]

Figure 2-42 File Manager Folder Contents

Other functions are available from the buttons down the right hand side of the window. They are described in
Table 2-2.

Table 2-2 Button Descriptions

Icon Description
Move up to the previous folder

Refresh the display by rereading the device

View the contents of the folder or file

Send a file from the computer to the device

Delete a file from the device
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Icon Description
Create a new document

Get all the files from a folder on the device to a folder
on the computer

Get the selected file from the device to the computer

Restart the device (requires the device's user ID/pass-
word)

[sc_ReydispEvolution_FileManagerExampleDocument, 1, --_--]

Figure 2-43 File Manager Example Document

Figure 2-43 shows the display of a document created. Documents created or files viewed from the device
are displayed on tab after the directory listing. When a file viewer tab is selected additional commands are
available, they are described in Table 2-3.
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Table 2-3 Additional Button Descriptions

Icon Description
Renames the document, this name is used when
sending the document to the device

Close the document tab

Send the document to the device
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Data Log Window

[sc_ReydispEvolution_DataLogIcon, 1, --_--]

Figure 2-44 Data Log Icon

[sc_ReydispEvolution_DataLogWindow, 1, --_--]

Figure 2-45 Data Log Window

The Data Log window displays a list of logged points over a period of time. The usual Open, Save, and Print
commands can be used on this window. This data can also be copied to a spreadsheet.
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Configure Communications
Reydisp can communicate with devices in several ways. These include Serial or USB Ports, TCP/IP ports and via
some control systems. All connections are managed through the Connection Manager (File > Connect). In
order to connect to a device the communication protocol, communication parameters, and the address of the
target device must be configured. The following section describes the various connection methods. Of course,
the user only needs to configure the types of connection in which they are interested.

Connecting a Device to a Serial Port or USB Port
It is beyond the scope of this manual to describe commissioning the communications features of a device in
detail; however, a brief description follows.
If the connection to the device is going to use its USB or electrical RS232 port connect it to the PC using a
suitable cable. If it uses the RS485 port, connect that to the PC using a suitable (Auto Device Enable (ADE)
supported) interface.
If a fibre optic connection is to be used the Transmit port (Tx) of the interface should connect to the Receive
(Rx) port of the device and the Tx port of the device should connect to the Rx port of the interface, as shown in
Figure 3-1.

[sc_ReydispEvolution_ConnectingADevice, 1, --_--]

Figure 3-1 Fibre Optic Connection

Star or Ring Connections
When using fibre optic connections to network several devices they can be connected in either a Star or a Ring
connection.
In a Star connection the port on the device is connected to a port on the hub. Each device will have a
dedicated communication link.

[sc_ReydispEvolution_StarConnection, 1, --_--]

Figure 3-2 Star Connection

In a Ring connection devices are connected to each other and to a single port on the interface. Serial
communication interface devices provide one fibre optic port for connecting a ring of Protection Devices. The
Tx from the interface goes to the Rx of the first device, the Tx of that device goes to the Rx of the second
device, whose Tx goes to the Rx of the third device etc. until finally the Tx of the last device goes to the Rx of
the interface as illustrated in Figure 3-3.

[sc_ReydispEvolution_RingConnection, 1, --_--]

Figure 3-3 Ring Connection

The main advantage of a ring connection is that it is inexpensive to implement. The main disadvantage is that
as there is a single communication link, and all devices act as repeaters, if you lose one device or one part of
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the fibre cable the whole network will cease to operate. When using a fibre optic ring configuration all devices
in the ring must have their Data echo setting, for the port in use, set to ON.
For any type of fibre optic connection the device's Line Idle setting should be set to match that of the
interface.
The remaining communications settings on the device's port, Baud rate and Parity, should be set to
match those that will be used in Reydisp.
If the devices are configured in a network, whether star, ring, or RS485, each should be assigned a different
address, and not be set to address zero.

Configuring Reydisp for Serial Communications

[sc_ReydispEvolution_ConnectionManager, 1, en_US]

Figure 3-4 Connection Manager

Open the Connection Manager (File > Connect), as illustrated in Figure 3-4. Select the appropriate serial
connection on the computer, e.g. Com 2, and click Properties.

ii NOTE
Only ports detected on the computer will be listed.

Set the Baud rate and Parity to match those set on the device, as illustrated in Figure 3-5.
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[sc_ReydispEvolution_ConfigureCommunications, 1, en_US]

Figure 3-5 Configure Communications

USB – RS232 Converters
It is becoming standard for computers, especially laptops, not to have an RS232 port. In most cases this is
being solved by buying an additional USB – RS232 connection cable. Some problems, for example, delays
introduced into the communications, have been encountered when using different types of these cables.
Therefore, when using USB converters please make the communications timeout defined in the Advanced
Options at least 250 ms.
For further information refer to 3.3 Advanced Communications Options.

Configuring TCP/IP Communications
The TCP/IP driver allows communication through a TCP/IP network. When using TCP/IP communications the
devices will either have a TCP/IP connection to an Ethernet network, or be connected to an external Ethernet
interface, for example the Lantronix UDS-10, via their serial port.

Configuring Reydisp for TCP/IP Communications
In the Connection Manager, select the appropriate TCP/IP connection and click Properties or select Add new
socket connection and click Add to create a new connection. Set the parameters to match those of the
system; Host Address to the IP addresses of the device or interface, and the Port Number to its Reydisp port.
An example is shown in Figure 3-6.
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[sc_ReydispEvolution_TCPConnection, 1, en_US]

Figure 3-6 Example TCP Connection

For further information refer to 3.3 Advanced Communications Options.

Configuring Modem Communications
The Modem driver allows communication through a telephone network. When using Modem communications
the devices will be connected to a remote Modem usually via their serial port.

Configuring Reydisp for Modem Communications
In the Connection Manager, select the appropriate PSTN Modem connection and click Properties or select Add
new Telephone connection and click Add to create a new connection. Set the parameters to match those of
the system. An example is shown in Figure 3-7.
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[sc_ReydispEvolution_TelephoneConnection, 1, en_US]

Figure 3-7 Example Telephone Connection

For further information refer to 3.3 Advanced Communications Options.

Configuring the Modem for Modem Communications
Click the Configure button, Figure 3-8 will appear. Select the Com Port of the PC connected to the modem
and the connection parameters. If required modify the Modem strings. Refer to the documentation for the
Modem for details of these values.
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[sc_ReydispEvolution_ModemSettings, 1, --_--]

Figure 3-8 Modem Settings
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Communications Tutorial
The user should now be able to communicate with their chosen relay. If any problems are encountered try
Relay > Communications > Synchronise or Relay > Communications > Clear. The indicator at the bottom
left corner of the main screen will inform as to the state of the communications. Clicking the Stop icon
at the bottom left of the main screen will stop communications. The functions for communicating with
the devices are all on the relay menu. They are described in detail along with the other commands in the
Command Reference. During communication events may appear in the spontaneous events window which
can be opened at any time to examine these events.

ii NOTE
Certain protection devices have a setting Operating Mode accessed either via a key switch on the fascia
or from the System Config sub menu of the Settings. The setting can be Remote, Local or Service
mode. These modes affect the communications function in the following way:
Remote Mode – All communication functions are available through the fibre optic ports.
Local Mode – Remote change of settings and remote control functions (e.g. close an output relay) through
the fibre optic ports are disabled.
Service Mode – Remote control functions (e.g. close an output relay) and sending spontaneous events and
measurands to the control system through the fibre optic ports are disabled.

Set the Address
The first thing to do is set the address of the target device in Reydisp. Use Relay > Set Address > Address to
set the address directly, or Relay > Set Address > Device Map to search for the device.

ii NOTE
When the device map builds the list it takes time as it has to poll all the addresses and wait for a response.
As there are unlikely to be devices on all addresses, an upper limit can be set for the address to poll; the
lower limit is always 1. Use the command Relay > Set Address > Device Map Limit to set the highest
address to poll.

Next try to get some information back from the device. Use Relay > Information > Get System Information
and there should be a response similar to that shown in Figure 3-9.

3.2
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[sc_ReydispEvolution_DeviceSystemInformation, 1, --_--]

Figure 3-9 System Information

Set the Device Time
To ensure the real time clock in the relay is correct select Relay > Control > Set Time and Date, and click Get
Relay Time button to get the time from the relay. Check the Synchronise and Synch to PC boxes, and then
press the Set Relay Time button to set the time.

Change Settings
To get a group of settings the user should use Relay > Settings > Get settings, after a short while the user
will be asked to select a settings group, then the Settings Editor is displayed.
To change the settings in the relay either use Relay > Settings > Update Changed Settings which sends the
settings changed to the group they came from, or Relay > Settings > Send Settings to send all the settings to
a group selected.
Get the active settings group with Relay > Settings > Get Setting Group. Activate a different group using
Relay > Settings > Set Setting Group.
A non-editable listing of a settings group (in English) is obtained by Relay > Settings > List Setting Group.

Get a Waveform
Download a waveform record with the command Relay > Waveform > Get Waveform Record. After a short
while the user will be asked to select a record, record number 1 is the latest. If no records are available trigger
a new waveform record remotely using Relay > Waveform > Trigger Waveform Record and repeat the Get
process. The data returned can be manipulated in the Waveform Display. All the data records in the relay can
be reset using Relay > Waveform > Reset Waveform Record. To display a list of the times the records were
recorded use the command Relay > Waveform > Get Data Directory.

Get the Events
Get the events using Relay > Events > Get Events. Select two events from the list, choose Relay > Events >
Events Time Difference and the time between the events will be displayed. This function is also available on
the Spontaneous Events window . The event store of the relay (but not the Spontaneous Events) can be reset
with Relay > Events > Reset Events.
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ii NOTE
Spontaneous events can be polled in the background while working by toggling Relay > Control > Auto
Poll on.

Clear the contents of the spontaneous event window with Relay > Events > Clear Spontaneous Events
Window, this doesn't affect the relay.

Issue Commands
Reydisp provides access to the General Commands of the device through the function Relay > Control >
General Commands. Other Control functions available are, reset the flag indication LED s (Relay > Control
> Reset Flags), close an output device (Relay > Control > Close Output Relay), file management (Relay >
Control > File Manager), and the direct control (Relay > Control > TeleType).

Other Information
Other information available from the relay are, faults (Relay > Information > Get Data Record), instruments
(Relay > Information > Monitor Instruments), and online help (Relay > Information > On-line Help).
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Advanced Communications Options

[sc_ReydispEvolution_AdvancedCommunicationsOptions, 1, en_US]

Figure 3-10 Advanced Communications Options Window

These settings should be changed with caution.
The Communications Timeout is the amount of time (in milliseconds) Reydisp waits for a node to respond
during data transfer.
The Device Map Timeout is the amount of time (in milliseconds) Reydisp waits for a node to respond
during a device map function.
The Generate Data Time is the amount of time (in milliseconds) Reydisp waits before sending a further
request to a node after a successful response.
The Retries setting is the number of attempts the communications driver will make before it reports a
communications failure. This setting is not used by all drivers, and therefore may not be shown.
Set Do NOT Check Communications Connection to checked and Reydisp will not test for a connection
on the PC port. This can be used if Reydisp cannot detect a connection automatically, or problems are
encountered. When checked Reydisp will assume the connection is satisfactory. This only applies to the serial
port driver.
Use the Parity Check option to switch parity checking on or off.

ii NOTE
Not all of these options are available on all drivers.

3.3
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ii NOTE
The Do NOT Check Communications Connection is often required to be selected when using a USB
or RS485 connection.
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File Menu
The File menu can be viewed from the top menu bar and has the following options:

• New From Template

• Connect

• Hangup

• Open
– Open Waveform with Default Viewer
– Open Waveform with Selected Viewer

• Save

• Save As

• Close

• Offline Revise Settings

• Print

• Print Options

• Printer Setup

• Recent files list

• Exit

[sc_ReydispEvolution_FileMenu, 1, en_US]

Figure 4-1 File Menu

4.1
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New From Template

[sc_ReydispEvolution_TemplatesIcon, 1, --_--]

Figure 4-2 Templates Icon

There are 2 types of template, settings templates and data templates. To view the templates available for each
type, click on the appropriate tab at the top of the dialog box. The view can be sorted alphabetically on the
contents of each column by clicking on that column's header label.

[sc_ReydispEvolution_TemplatesTabs, 1, en_US]

Figure 4-3 Templates Tabs

Settings Templates

[sc_ReydispEvolution_TemplatesSettings, 1, --_--]

Figure 4-4 Settings Templates

Settings templates allow setting for devices to be created offline. Templates are available for the different
software variants and I/O configurations of each device. The templates box now contains a Find facility. To
search, type all or part of an item into the field and click the Start button (→). This will start to search from the
top of the list. To continue the search click the next button (↓). Select the template to open from the list and
then click OK.
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Data Templates

[sc_ReydispEvolution_TemplatesData, 1, en_US]

Figure 4-5 Data Templates

Data templates show examples of data to highlight the features of Reydisp. They are provided to allow users
to become familiar with the Waveform, Events and Faults displays without needing to be connected to a
device. Select the template to open from the list and then click OK.

Connect

[sc_ReydispEvolution_ConnectIcon, 1, --_--]

Figure 4-6 Connect Icon
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[sc_ReydispEvolution_ConnectionManager, 1, en_US]

Figure 4-7 Connection Manager

The Connection Manager lists the different connections that are available. These connections are listed in
groups. To connect to a device, select a connection from the list and click the Connect button. Connection
types include connecting to a serial port and a TCP/IP connection.
A connection can be set as the default, shown by the tick mark (✓) imposed over the icon, to be automatically
opened on starting Reydisp. You can manage the default with the Set as Default and Clear Default buttons.
Certain types of connection can have additional connections added. In this case an (Add new socket connec-
tion> icon will be displayed in the group. Selecting it and clicking the Add button will display a dialog box
where the connection parameters can be entered.
To change the parameters of a connection, select it and press the Properties button.
Connections that have been added by the user can be deleted by pressing the Delete button.

Hangup

[sc_ReydispEvolution_Hangup Icon, 1, --_--]

Figure 4-8 Hangup Icon
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Use this command to close a communications connection previsc_ReydispEvolution_OpenWaveformDefaul-
tIcon, 1ously opened by Connect.

Open

[sc_ReydispEvolution_OpenMenu, 1, en_US]

Figure 4-9 Open Menu

[sc_ReydispEvolution_OpenIcon, 1, --_--]

Figure 4-10 Open Icon

Use to open a file. Files can contain Settings, Waveform Data, Text Data or other data.

Open Waveform with Default Viewer

[sc_ReydispEvolution_OpenWaveformDefaultIcon, 1, --_--]

Figure 4-11 Open Waveform with Default Viewer Icon

Open a waveform using the default viewer settings for that type of device rather than any viewer settings
stored in the file being opened. This option is ignored if you then open a file other than a waveform.
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Open Waveform with Selected Viewer

[sc_ReydispEvolution_OpenWaveformSelectedIcon, 1, --_--]

Figure 4-12 Open Waveform with Selected Viewer Icon

Open a waveform using the viewer chosen from the displayed list rather than any viewer settings stored in the
file being opened. This option is ignored if you then open a file other than a waveform.

Save

[sc_ReydispEvolution_SaveIcon, 1, --_--]

Figure 4-13 Save Icon

Save the data of the active window using the present name. If this is data has not previously been saved it
performs a Save As.

Save As

[sc_ReydispEvolution_SaveAsIcon, 1, --_--]

Figure 4-14 Save As Icon

Save the data of the active window using a new name.
The user can also use this command to export data as a different type of file by selecting from the Save File as
Type list. Depending on which window is active, there are different options in this list for saving or exporting
data, described in Table 4-1.

Table 4-1 Waveform Window

File Type Extension Description
Reyrolle format version 2 RDF2 Reyrolle proprietry binary file format

version 2
Reyrolle format version 1 DAT Reyrolle proprietry binary file format

version 1
Comtrade 1999 CFG Comtrade 1999 compatible file set
Comtrade 1991 CFG Comtrade 1991 compatible file set
Real values TXT Text file containing data channel values
DADiSP DAT DADiSP compatible file

Events, Data Logs and Text files are all saved in ASCII format text (TXT) files.
Data View files are saved as Windows format INI files.
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Close

[sc_ReydispEvolution_CloseIcon, 1, --_--]

Figure 4-15 Close Icon

Choosing this command closes the active window.

Offline Revise Settings

[sc_ReydispEvolution_OfflineReviseSettingsIcon, 1, --_--]

Figure 4-16 Offline Revise Settings Icon

This command allows the conversion of a settings file into a file for a different type of relay.
Open the settings file to convert and make it the active window. The Offline Revise Settings command can
then be selected and the user can choose the type of file to convert to from the list or open another file. To
use this command the file to be converted to must be in the list or there must be an example of the type.

[sc_ReydispEvolution_TemplatesSettings, 1, en_US]

Figure 4-17 Settings Window

On completion the source file window will be minimized and the new settings file shown opened.

Print

[sc_ReydispEvolution_PrintIcon, 1, --_--]

Figure 4-18 Print Icon

This option will print the contents of the active window.

Command Reference
4.1 File Menu

74 Reydisp Evolution 32, Software, Manual
C53000-H7050-C032-1, Edition 03.2023



Print Options

[sc_ReydispEvolution_PrintOptionsIcon, 1, --_--]

Figure 4-19 Print Options Icon

Set the user options for Waveform printouts. Information relating to the print is placed in the Comment field.
Information identifying the origin of the print is placed in the User field. Either field can be left blank.

Printer Setup

[sc_ReydispEvolution_PrinterSetupIcon, 1, --_--]

Figure 4-20 Printer Setup Icon

This option allows the user to set the printers parameters prior to printing.

Recent Files List

[sc_ReydispEvolution_RecentFilesListIcon, 1, --_--]

Figure 4-21 Recent Files List Icon

Shows the files recently opened allowing quick selection for reopening. The files have an index number 0 to 9
next to them that can be used as a shortcut key. The most recently opened file is always at the top of the list
index 0.

Exit

[sc_ReydispEvolution_ExitIcon, 1, --_--]

Figure 4-22 Exit Icon

Choosing this option will exit the Reydisp Evolution application.
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Edit Menu
The Edit menu can be viewed from the top menu bar and has the following options:

• Undo

• Cut

• Copy

• Paste

• Clear

• Select All

• Select None

• Compare Setting Groups

• Remove Setting Highlights

ii NOTE
The functions of the Edit menu are dependant on which display window is active. Not all functions are
available on all pages.

[sc_ReydispEvolution_EditMenu, 1, en_US]

Figure 4-23 Edit Menu

Undo

[sc_ReydispEvolution_UndoIcon, 1, --_--]

Figure 4-24 Undo Icon

Choosing this option will undo the previous edit operation.

4.2
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Cut

[sc_ReydispEvolution_CutIcon, 1, --_--]

Figure 4-25 Cut Icon

Choosing this option copies the selection to the clipboard and deletes it from it's original window.

Copy

[sc_ReydispEvolution_CopyIcon, 1, --_--]

Figure 4-26 Copy Icon

This option copies the window contents to the clipboard. If the window contains a selection, a dialog box is
opened allowing the user to select whether to copy all the contents, or just the selection.

Paste

[sc_ReydispEvolution_PasteIcon, 1, --_--]

Figure 4-27 Paste Icon

This will paste from the clipboard into the active window.

Clear

[sc_ReydispEvolution_ClearIcon, 1, --_--]

Figure 4-28 Clear Icon

This option will clear the present selection from the active window.

Select All

[sc_ReydispEvolution_SelectAllIcon, 1, --_--]

Figure 4-29 Select All Icon

This option will select all items on the active window.
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Select None

[sc_ReydispEvolution_SelectNoneIcon, 1, --_--]

Figure 4-30 Select None Icon

This will remove any selection from the items on the active window.

Compare Setting Groups

[sc_ReydispEvolution_CompareSettingGroupsIcon, 1, --_--]

Figure 4-31 Compare Setting Groups Icon

[sc_ReydispEvolution_CompareSettingWindow, 1, en_US]

Figure 4-32 Compare Settings Window

This function compares 2 settings groups. The settings should be opened in 2 Settings editors. Differences in
the settings will be highlighted in different colours. If the settings is new, or significantly different it will be
highlighted in the Attention color. If the setting has a different definition, for example, it's range has changed,
it will be highlighted in the Range color. Differences in value will be shown in the Changed color. These colors
can be set as an option using Options > Evolution. If there are differences the windows will be rearranged to
show the 2 compared Settings editors tiled in the main window, with the other windows minimized, as shown
in Figure 4-33. The Remove Highlights command can be used to remove the highlights from the active
Settings editor. While settings are highlighted after a comparison the Update Changed Settings command is
unavailable until the highlight is removed. From a comparison window use the Send All Settings command to
modify the relay settings.
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[sc_ReydispEvolution_CompareSettings, 1, en_US]

Figure 4-33 Comparing Settings

Remove Setting Highlights

[sc_ReydispEvolution_RemoveSettingHighlightsIcon, 1, --_--]

Figure 4-34 Remove Setting Highlights Icon

Remove the Attention highlights from a Settings editor, for example, after a compare setting groups function.
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View Menu
The View menu can be viewed from the top menu bar and has the following options:

• Properties

• Zoom In

• Zoom Out

• Show Full

• Vertical Zoom In

• Vertical Zoom Out

• Highlight Samples

• Select cursor

• Relative Scaling

• Auto Save Views As Device Default

• Save Views As Device Default Now!

• Save Views As ? Now!

[sc_ReydispEvolution_ViewWindow, 1, en_US]

Figure 4-35 View Menu

Properties

[sc_ReydispEvolution_PropertiesIcon, 1, --_--]

Figure 4-36 Properties Icon

4.3
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The Properties dialog configures the active Waveform data display window.

[sc_ReydispEvolution_PropertiesTabs, 1, en_US]

Figure 4-37 Properties Tabs

It consists of a number of tabbed pages, as illustrated in Figure 4-37.

Views Tab

[sc_ReydispEvolution_ViewsTabs, 1, en_US]

Figure 4-38 Views Tab

The Views tab lists the data configuration for each signals tab on the data display window.
Use the New, Edit, and Delete buttons to manage views. To order them the up ↑ and down ↓ buttons can
be used. Pressing either the New or Edit buttons will open the Configure View dialog box.
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[sc_ReydispEvolution_EditView, 1, en_US]

Figure 4-39 Configure View

The Configure View dialog box allows the user to change the items displayed on a tab in the data window.
The name of the display tab can be changed in the Title editor.
The left list contains a list of all available signals. Select a signal and use the → to move it to the right hand
definitions list. To put multiple signals on one graph axis select several items before clicking the button. To
remove signals from the tab select the definition in the right hand list and press the ← button.
The order of the definitions can be changed by using the ↑ and ↓ buttons.
The display tabs are only shown when the checkbox next to their definition is checked.
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Signals Tab

[sc_ReydispEvolution_PropertiesSignalsTabs, 1, en_US]

Figure 4-40 Signals Tab

The Signals tab displays a list of the available Analogue signals.
To create a new function click Create New Signal and follow the on screen wizard.
You can edit the properties of a signal by selecting it in the left list and pressing the Edit button, the Edit
Analogue Channel dialog box is displayed.
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[sc_ReydispEvolution_EditAnalogueChannel, 1, en_US]

Figure 4-41 Edit Analogue Channel

This dialog box allows changing of the Analogue channel parameters.
The text values for Name, Phase, Circuit, and Units can be changed in the respective editors. This will
affect the labels displayed.
The numeric factors A, B, and Skew can be changed in their editors, this will affect display of the signal.
The Pri:Sec boxes define the Primary to Secondary ratio whether the record is recorded in primary (P) or
secondary (S) values.
The color the signal is drawn in can be changed with the Colour button.
The User Display Min/Max control and checkbox allow the user to override the max and min values for a
signal by setting their own and therefore keep the range displayed constant. This feature is turned on and off
using the checkbox.
Signals can be deleted by selecting them and pressing the Delete button.

ii NOTE
Signals created will be saved in the file when the data record is saved. Deleted signals are completely
removed and that data lost.
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Miscellaneous Tab

[sc_ReydispEvolution_PropertiesMiscellaneousTabs, 1, en_US]

Figure 4-42 Miscellaneous Tab

The Miscellaneous tab holds settings which configure the look of the waveform display. They include color
schemes and various display and print styles.
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Styles

• Analogue Waveform Borders – This setting toggles the border effect of an Analogue waveform. This will
also remove the shading effect. As illustrated in .

[sc_ReydispEvolution_AnalogueWaveformBorders, 1, --_--]

Figure 4-43 Analogue Waveform Borders

• Analogue Pad Shading – This setting toggles the shading background effect of an Analogue waveform.
As illustrated in Figure 4-44.

[sc_ReydispEvolution_AnaloguePadShading, 1, --_--]

Figure 4-44 Analogue Pad Shading

• Digital Signal Borders – This setting toggles the border effect of a Digital waveform. This will also remove
the shading effect. As illustrated in Figure 4-45.

[sc_ReydispEvolution_DigitalSignalBorders, 1, --_--]

Figure 4-45 Digital Signal Borders

• Digital Pad Shading – This setting toggles the shading background effect of a Digital waveform. As
illustrated in Figure 4-46.

[sc_ReydispEvolution_DigitalPadShading, 1, --_--]

Figure 4-46 Digital Pad Shading
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• Digital Item Shading – This setting toggles the item shading effect of a Digital waveform. As illustrated in
Figure 4-47.

[sc_ReydispEvolution_DigitalItemShading, 1, --_--]

Figure 4-47 Digital Item Shading

• Print Analogue Waveform Borders – This setting toggles the printing of Analogue waveform borders and
shading on printouts. As illustrated in Figure 4-48.

[sc_ReydispEvolution_PrintAnalogueWaveformBorders, 1, --_--]

Figure 4-48 Print Analogue Waveform Borders

• Print Waveforms in Monochrome – This setting toggles printing the Waveforms in Monochrome. As
illustrated in Figure 4-49.

[sc_ReydispEvolution_PrintWaveformsInMonochrome, 1, --_--]

Figure 4-49 Print Waveforms in Monochrome
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Color Scheme

• Color Selection – These settings allow selection of color schemes for drawing waveform displays, either
from a selection of predefined schemes, a comparison of which is shown in Figure 4-50, or selected by
the user.

[sc_ReydispEvolution_ColorScheme, 1, --_--]

Figure 4-50 Color Scheme Example

• Border – The Border value defines the color of the item border.

• Dark Shade – The Dark Shade value defines the darkest color of the item shading.

• Light Shade – The Light Shade value defines the lightest color of the item shading.

• Digital Shade – The Digital Shade value defines the basic shading color of a digital item.

Zoom In

[sc_ReydispEvolution_ZoomInIcon, 1, --_--]

Figure 4-51 Zoom In Icon

This option will expand the region on the display between the cursors.

Zoom Out

[sc_ReydispEvolution_ZoomOutIcon, 1, --_--]

Figure 4-52 Zoom Out Icon

Choosing this option slightly reduces the zoom.

Show Full

[sc_ReydispEvolution_ZoomFullIcon, 1, --_--]

Figure 4-53 Show Full Icon

This option removes the zoom and shows all the data.
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Vertical Zoom In

[sc_ReydispEvolution_VerticalZoomInIcon, 1, --_--]

Figure 4-54 Vertical Zoom In Icon

This option vertically expands the waveform display area.
This function increases the vertical resolution of the signals by reducing the number of signals drawn in the
view area, thus giving more space to the remainder. The signals removed can be scrolled back into view using
the scroll bar on the right of the window.

[sc_ReydispEvolution_DataHeaderWindow, 1, en_US]

Figure 4-55 Data Header Window Not Zoomed
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[sc_ReydispEvolution_VerticalZoomIn, 1, en_US]

Figure 4-56 Data Header Window with Vertical Zoom

Vertical Zoom Out

[sc_ReydispEvolution_VerticalZoomOutIcon, 1, --_--]

Figure 4-57 Vertical Zoom Out Icon

This option vertically reduces the waveform display area.

Highlight Samples

[sc_ReydispEvolution_HighlightSamplesIcon, 1, --_--]

Figure 4-58 Highlight Samples Icon

This option allows the user to toggle the waveforms to display highlighted sample points.

[sc_ReydispEvolution_WaveformWithoutHighlightedPoints, 1, --_--]

Figure 4-59 Waveform without Highlighted Points
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[sc_ReydispEvolution_WaveformWithHighlightedPoints, 1, --_--]

Figure 4-60 Waveform with Highlighted Points

Select Cursor

[sc_ReydispEvolution_SelectCursorIcon, 1, --_--]

Figure 4-61 Select Cursor Icon

Selects which cursor is moved by the keyboard ← and → keys. The presently selected cursor is shown with a
small arrow at its top.

Relative Scaling

[sc_ReydispEvolution_RelativeScalingIcon, 1, --_--]

Figure 4-62 Relative Scaling Icon

When this option is turned on, Analogue signals in a Waveform Display tab are scaled with respect to signals
of the same type, for example, all voltages are drawn using the same range. When this option is off the signals
are scaled only with respect to themselves.
In the following example relative scaling is turned on.
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[sc_ReydispEvolution_RelativeScalingOn, 1, en_US]

Figure 4-63 Relative Scaling On

The following example shows the same data with relative scaling turned off. Channels with small values are
shown as noise.

[sc_ReydispEvolution_RelativeScalingOff, 1, en_US]

Figure 4-64 Relative Scaling Off

Command Reference
4.3 View Menu

92 Reydisp Evolution 32, Software, Manual
C53000-H7050-C032-1, Edition 03.2023



Auto Save Views As Device Default

[sc_ReydispEvolution_AutoSaveAsDeviceDefaultIcon, 1, --_--]

Figure 4-65 Auto Save Views As Device Default Icon

With this option on, when a waveform display window is closed, the present waveform view configuration is
automatically saved as the new default for this type of device. It is the automatic equivalent of using the Save
Views As Device Default Now! command.

Save Views As Device Default Now!

[sc_ReydispEvolution_SaveViewsAsDeviceDefaultNowIcon, 1, --_--]

Figure 4-66 Save Views As Device Default Now! Icon

This command immediately saves the present view configuration as the new default for this type of device.
This configuration will be used the next time a waveform record is downloaded from a device, or if a file
without a configuration is opened, or with the Open Waveform with Default Viewer command.

Save Views As ? Now!

[sc_ReydispEvolution_SaveViewsAsNowIcon, 1, --_--]

Figure 4-67 Save Views As ? Now! Icon

This command immediately saves the present view configuration under a user supplied name. The saved
configuration can be used with the Open Waveform with Selected Viewer command.
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Relay Menu
The Relay menu can be viewed from the top menu bar and has the following options:

• Set Address
– Address
– Device Map
– Device Map Limit
– Line Selector

• Login
– Login
– Logout

• Settings
– Get Settings
– Update Changed Settings
– Send All Settings
– Get Active Setting Group Number
– Set Active Setting Group Number
– List Settings Group
– Compare Setting Groups
– Remove Setting Highlights

• Events
– Get Events
– Reset Events
– Events Time Difference
– Clear Spontaneous Messages Window

• Waveform
– Get Waveform Record
– Trigger Waveform Record
– Reset Waveform Records
– Get Data Directory

• Data Records
– Get Data Fault Record
– Get Data Log Record
– Reset Data Log Record
– Get Data Report File
– Reset Data Report Files
– View Data Log As Comtrade

4.4
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• Information
– Monitor Instruments
– Monitor Waveforms
– Get System Information
– Start General Interrogation
– OnLine Help

• Control
– Auto Poll
– Reset Flags
– Close Output Relay
– Set Time and Date
– TeleType
– General Command
– Relay File Manager

• Archive Functions
– Get All Data
– Send Archived Settings

• Communications
– Clear
– Synchronise

[sc_ReydispEvolution_RelayMenu, 1, en_US]

Figure 4-68 Relay Menu
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Set Address

[sc_ReydispEvolution_SetAddress, 1, en_US]

Figure 4-69 Set Address Menu

Address

[sc_ReydispEvolution_AddressIcon, 1, --_--]

Figure 4-70 Address Icon

This option allows the user to set the address to use for communicating with the device. This should be the
same as the address which has been set via the device's front panel.

Device Map

[sc_ReydispEvolution_DeviceMapIcon, 1, --_--]

Figure 4-71 Device Map Icon

This option will poll addresses looking for devices that may be present. The addresses polled are from 1 to
the limit set by the Device Map Limit command. It produces a list of any device found. The address is set
either by selecting the device and pressing OK, or double clicking on the item in the list.
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[sc_ReydispEvolution_DeviceMapDialog, 1, --_--]

Figure 4-72 Device Map Dialog Box

ii NOTE
The device map function is not available with certain communications drivers.

Device Map Limit

[sc_ReydispEvolution_DeviceMapLimitIcon, 1, --_--]

Figure 4-73 Device Map Limit Icon

This option sets the upper limit for the Device Map command to poll. This command saves polling all
addresses when there are only a few devices in the network.

Line Selector

[sc_ReydispEvolution_LineSelectorIcon, 1, --_--]

Figure 4-74 Line Selector Icon

Used with some communications drivers and allows setting of the line selector value. This value is dependant
on the system.

Command Reference
4.4 Relay Menu

Reydisp Evolution 32, Software, Manual 97
C53000-H7050-C032-1, Edition 03.2023



Login

[sc_ReydispEvolution_LoginMenu, 1, en_US]

Figure 4-75 Login Menu

Login

[sc_ReydispEvolution_LoginIcon, 1, --_--]

Figure 4-76 Login Icon

Reydisp has to be logged into the device before it can perform functions which will alter the device, for
example, Close an Output Relay or Changing Settings.
To retrieve information from the device there is no need to be logged in. Enter the device's user ID/password
into the field (shown in Figure 4-77), the user ID/password will be shown as **** and not be echoed on the
screen, then click Login.

[sc_ReydispEvolution_LoginDialog, 1, en_US]

Figure 4-77 Login Dialog Box

Reydisp Evolution stores a default password which it tries to use to login to the device. If this password is
valid it will automatically login when required. If the automatic login fails the Login Dialog Box (shown in
Figure 4-77) will be displayed and the correct user ID/password should be entered. If this password should be
saved as the new default for automatic logins check the Save as New Default box before clicking Login.
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ii NOTE
Some Reyrolle devices refer to a user password. On these devices and in Reydisp Evolution, the setting
password is a confirmation mechanism to prevent unauthorized access from the front fascia or over the
rear serial communication channel(s).
The Control password is a confirmation mechanism to prevent the unauthorized operation of control
operations and commands from the Control menu on the relay fascia.

Logout

[sc_ReydispEvolution_LogoutIcon, 1, --_--]

Figure 4-78 Logout Icon

This option is used to logout Reydisp from a device. This command is complementary to the Login command.

Settings

[sc_ReydispEvolution_SettingsMenu, 1, en_US]

Figure 4-79 Settings Menu

Get Settings

[sc_ReydispEvolution_GetSettingsIcon, 1, --_--]

Figure 4-80 Get Settings Icon

This option allows the user to read one group of settings from the device into a Settings Editor window. The
user will be prompted to enter the group required.
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[sc_ReydispEvolution_ActivateSettingsGroupDialog, 1, en_US]

Figure 4-81 Activate Settings Group Dialog Box

Update Changed Settings

[sc_ReydispEvolution_UpdateSettingsIcon, 1, --_--]

Figure 4-82 Update Changed Settings Icon

This updates the setting(s) that have changed since the last upload or download to the original group in the
device.

Send All Settings

[sc_ReydispEvolution_SendAllSettingsIcon, 1, --_--]

Figure 4-83 Send All Settings Icon

This sends the complete settings from a Settings Editor window to a group specified by the user.

ii NOTE
To upload settings to the device the user needs to make sure the Settings Editor window containing the
settings is active (topmost). If a window other than a Settings Editor is active the Update Changed
Settings and Send All Settings commands are disabled.
When uploading settings to the device Reydisp Evolution checks that the settings are compatible with the
designated device. If they are incompatible the settings are not uploaded and a conversion process takes
place.
During the conversion process an additional settings window is opened containing settings for the destina-
tion device with the compatible values from the original settings copied to it.
Incompatible settings are highlighted in the attention color; see Evolution Options. The user should check
these settings. If the destination device had fewer settings than the source device, but all its settings were
compatible the difference will be flagged, however, no settings will be highlighted for attention. When the
user is satisfied the settings in the new window are correct choose Send All Settings to begin the upload
with the converted settings.

Get Active Setting Group Number

[sc_ReydispEvolution_GetActiveSettingGroupNumberIconIcon, 1, --_--]

Figure 4-84 Get Active Setting Group Number Icon

This gets the setting group in the device which is presently active.
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[sc_ReydispEvolution_GetActiveSettingGroupNumberDialog, 1, --_--]

Figure 4-85 Get Active Setting Group Number Dialog Box

Set Active Setting Group Number

[sc_ReydispEvolution_SetActiveSettingGroupNumberIcon, 1, --_--]

Figure 4-86 Set Active Setting Group Number Icon

This sets a setting group in the device to be active. The user is asked for the group to activate in Figure 4-87.

[sc_ReydispEvolution_SetActiveSettingGroupDialog, 2, en_US]

Figure 4-87 Set Active Setting Group Number Dialog

List Settings Group

[sc_ReydispEvolution_ListSettingsGroupIcon, 1, --_--]

Figure 4-88 List Settings Group Icon

This option allows the user to get a listing of a setting group in English.
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[sc_ReydispEvolution_ListSettingsGroupDialog, 1, --_--]

Figure 4-89 List Settings Group Dialog
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Events

[sc_ReydispEvolution_EventsMenu, 1, en_US]

Figure 4-90 Events Menu

Get Events

[sc_ReydispEvolution_GetEventsIcon, 1, --_--]

Figure 4-91 Get Events Icon

This tool gets a list of the historical events from the device into an Events window.

Reset Events

[sc_ReydispEvolution_ResetEventsIcon, 1, --_--]

Figure 4-92 Reset Events Icon

This tool resets the internal historical event store of the device.

Events Time Difference

[sc_ReydispEvolution_EventsTimeDifferenceIcon, 1, --_--]

Figure 4-93 Events Time Difference Icon

This option displays the time difference between 2 events in the events list. Before selecting this function the
user must have only 2 events selected in the list.
When the user has only 2 events selected the time difference is automatically displayed in the status bar at the
bottom of the Event window.
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The format of the time difference is n Days, Hours : Minutes : Seconds e.g. 2 Days, 10:35:12.345
is 2 days, 10 hours, 35 minutes, 12.345 seconds between events. If the user selects an event which does not
have a time stamp or a blank line, its time is taken as the previous time stamp in the list.

[sc_ReydispEvolution_EventsTimeDifferenceDialog, 1, --_--]

Figure 4-94 Events Time Difference Dialog

Clear Spontaneous Messages Window

[sc_ReydispEvolution_ClearSpontaneousMessagesWindowIcon, 1, --_--]

Figure 4-95 Clear Spontaneous Messages Window Icon

This clears the information from the Spontaneous Messages window . This function does not affect the device.

Waveform

[sc_ReydispEvolution_WaveformMenu, 1, en_US]

Figure 4-96 Waveform Menu
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Get Waveform Record

[sc_ReydispEvolution_GetWaveformRecordIcon, 1, --_--]

Figure 4-97 Get Waveform Record Icon

This option gets the wave form record, specified by the user, from the device into the Data Header window. A
list of available records will be displayed with their timestamp; the most recent record is always number one.

[sc_ReydispEvolution_GetWaveformRecordDialog, 1, --_--]

Figure 4-98 Get Waveform Record Dialog Box

For some newer devices additional information about the type or record is given, as shown in Figure 4-99 and
Figure 4-100.

[sc_ReydispEvolution_GetWaveformRecordDialogNewerDevice, 1, en_US]

Figure 4-99 Get Waveform Record Dialog Box Newer Device Example 1
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[sc_ReydispEvolution_GetWaveformRecordDialogNewerDevice2, 2, en_US]

Figure 4-100 Get Waveform Record Dialog Box Newer Device Example 2

Trigger Waveform Record

[sc_ReydispEvolution_TriggerWaveformRecordIcon, 1, --_--]

Figure 4-101 Trigger Waveform Record Icon

This triggers the device to immediately record a waveform record. This can then be retrieved be the Get
Waveform Record function. The record will replace the oldest record in the device.

Reset Waveform Records

[sc_ReydispEvolution_ResetWaveformRecordsIcon, 1, --_--]

Figure 4-102 Reset Waveform Records Icon

This option will reset the device's waveform record store. This command will permanently delete the records.

Get Data Directory

[sc_ReydispEvolution_GetDataDirectoryIcon, 1, --_--]

Figure 4-103 Get Data Directory Icon

This allows the user to read the Data Directory listing from the device. This shows the times at which the
records were stored.
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[sc_ReydispEvolution_GetDataDirectoryDialog, 1, --_--]

Figure 4-104 Get Data Directory Dialog Box

Data Records

[sc_ReydispEvolution_DataRecordsMenu, 1, en_US]

Figure 4-105 Data Records Menu

Get Data Fault Record

[sc_ReydispEvolution_GetDataFaultRecordIcon, 1, --_--]

Figure 4-106 Get Data Fault Record Icon

This option reads the list of data records from the device into an Edit window. This was formally the get faults
command. The format of the record is as follows:
<Description Number><Date dd/mm/yy><Time><1st Phase Details>to<nth Phase Details>
For example:
FAULT1 15/01/96 02:06:05.0500 G1 PHASE A <:S> IA=1.01xIn PHASE B <LS> IB=1.01xIn PHASE C
IC=0.00xIn EARTH FAULT IE=0.00xIn
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Get Data Log Record

[sc_ReydispEvolution_GetDataLogRecordIcon, 1, --_--]

Figure 4-107 Get Data Log Record Icon

This command retrieves a Data Log record from a device. On starting this command the dialog box shown in
Figure 4-108 will open.

[sc_ReydispEvolution_GetDataLogRecordDialog, 1, --_--]

Figure 4-108 Get Data Log Record Dialog Box

The user may either download all data records, or a selection between 2 times. Select the All or Selected
control as required. When in Selected mode the From and To controls are available. Use these to specify a
range of samples to download. The newest and oldest points are shown next to the From and To titles.
While this dialog is open the device is still recording. The user can use the Refresh Date/Time button to
update the available sample point information.

Reset Data Log Record

[sc_ReydispEvolution_ResetDataLogRecordIcon, 1, --_--]

Figure 4-109 Reset Data Log Record Icon

This command resets the internal Data Log of the device.

Get Data Report File

[sc_ReydispEvolution_GetDataReportFileIcon, 1, --_--]

Figure 4-110 Get Data Report File Icon
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This command retrieves a Data record from a device. On starting this command the dialog box shown in
Figure 4-111 will open listing any records available.

[sc_ReydispEvolution_GetDataReportFileDialog, 1, --_--]

Figure 4-111 Get Data Report File Dialog Box

Select a record from the list and click OK. Once retrieved the record is displayed as shown in Figure 4-112.

[sc_ReydispEvolution_GetDataReportFileDialogRetrieved, 1, --_--]

Figure 4-112 Get Data Report File Dialog Box Retrieved
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Reset Data Report Files

[sc_ReydispEvolution_ResetDataReportFilesIcon, 1, --_--]

Figure 4-113 Reset Data Report Files Icon

This command resets the internal Data Report store of the device.

View Data Log As Comtrade

[sc_ReydispEvolution_ViewDataLogAsComtradeIcon, 1, --_--]

Figure 4-114 View Data Log As Comtrade Icon

This command converts an open Data Log into a graphical Comtrade view. This view can be manipulated as
with any signals window.

[sc_ReydispEvolution_ViewDataLogAsComtradeExample, 1, --_--]

Figure 4-115 View Data Log As Comtrade Example
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Information

[sc_ReydispEvolution_InformationMenu, 1, en_US]

Figure 4-116 Information Menu

Monitor Instruments

[sc_ReydispEvolution_MonitorInstrumentsIcon, 1, --_--]

Figure 4-117 Monitor Instruments Icon

This option connects to the device and displays instruments in the Instrument window.
The Instrument window contains a list of instruments available in the device. Each has a checkbox next to it.
Instruments will only be polled if the box is checked. The more instruments that are activated the slower the
polling cycle.
The device address polled is that set when the command is executed. Instrument windows can be open
simultaneously. To poll other addresses change the address using Address or Device Map and select this
command again.

Monitor Waveforms

[sc_ReydispEvolution_MonitorWaveformsIcon, 1, --_--]

Figure 4-118 Monitor Waveforms Icon

This command monitors a device for new waveform fault records. Any that occur are automatically down-
loaded and saved in the Monitor folder of the Application Settings folder. The files saved can be opened in
Reydisp in the usual manner. While monitoring devices no other actions can be performed in Reydisp. An
example of the monitor waveforms dialog box is shown in Figure 4-119. Click Stop to end the monitoring
session.
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[sc_ReydispEvolution_MonitorWaveformsExample, 1, en_US]

Figure 4-119 Monitor Waveforms Example

Get System Information

[sc_ReydispEvolution_GetSystemInformationIcon, 1, --_--]

Figure 4-120 Get System Information Icon

This option gets the System Information from the device. An example is shown in Figure 4-121.

[sc_ReydispEvolution_GetSystemInformationExample, 1, en_US]

Figure 4-121 Get System Information Example
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Start General Interrogation

[sc_ReydispEvolution_StartGeneralInterrogationIcon, 1, --_--]

Figure 4-122 Start General Interrogation Icon

This initiates a General Interrogation sequence in the device. The Results are displayed in the Spontaneous
Messages window with a cause of transmission GI.

OnLine Help

[sc_ReydispEvolution_OnLineHelpIcon, 1, --_--]

Figure 4-123 OnLine Help Icon

This allows the user to get the inbuilt (Online) help from a protection device into an Edit window. Only certain
devices support this feature.
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[sc_ReydispEvolution_OnLineHelpExample, 1, --_--]

Figure 4-124 OnLine Help Example
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Control

[sc_ReydispEvolution_ControlMenu, 1, en_US]

Figure 4-125 Control Menu

Auto Poll

[sc_ReydispEvolution_AutoPollIcon, 1, --_--]

Figure 4-126 Auto Poll Icon

This tool toggles background Auto Polling of the device on or off. Auto polling continuously polls for sponta-
neous events from the device. Reydisp will poll the active nodes returned by the device map.

Reset Flags

[sc_ReydispEvolution_ResetFlagsIcon, 1, --_--]

Figure 4-127 Reset Flags Icon

This resets the device's Flag Indication LED lights.
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Close Output Relay

[sc_ReydispEvolution_CloseOutputRelayIcon, 1, --_--]

Figure 4-128 Close Output Relay Icon

This tool closes an Output Relay of the protection device. The Relay pulses closed for a minimum operate
time that is either a predefined or user defined time (depending on the type of device). The number of the
Relay to close will be requested from the user, as shown in Figure 4-129. To close select the correspondingly
numbered button. If the user wishes to test several output Relays, checking the Keep Visible box in the dialog
box shown in Figure 4-129 will keep the box open after a Relay has been selected, otherwise it will close.

[sc_ReydispEvolution_CloseOutputRelayDialog, 1, en_US]

Figure 4-129 Close Output Relay Dialog Box

Set Time and Date

[sc_ReydispEvolution_SetTimeAndDateIcon, 1, --_--]

Figure 4-130 Set Time and Date Icon

Set the time by using the Hour and Minute editors and Scroll Bars, or move the hands on the clock. Set the
Date in a similar manner with the Date controls and calendar. The time displayed in this dialogue is initially
that of the computers clock.
Field Description
Address Sets the address of the device whose clock to set
Get Relay Time Gets the time from the device at address
Set Relay Time Sets the time of the device at address
Get Computer Time Gets the time of the computers clock
Synchronise Performs synchronise time function for the devices

on a network. When the box is checked the address
control and Get Relay Time button are disabled.

Synch to PC Synchronises to the time of the PC when the Set
Relay Time button is pressed, rather than that of the
time control.

DST (Summer Time) Used in conjunction with Synchronise to set the
summer time flag on or off during time synchronisa-
tion.
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[sc_ReydispEvolution_SetTimeAndDateDialog, 1, en_US]

Figure 4-131 Set Time and Date Dialog Box

TeleType

[sc_ReydispEvolution_TeleTypeIcon, 1, --_--]

Figure 4-132 TeleType Icon

This opens a TeleType window for direct communications with a device.

General Command

[sc_ReydispEvolution_GeneralCommandIcon, 1, --_--]

Figure 4-133 General Command Icon

This opens the General Command window.

Relay File Manager

[sc_ReydispEvolution_RelayFileManagerIcon, 1, --_--]

Figure 4-134 Relay File Manager Icon

This opens the File Manager window.
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Archive Functions

[sc_ReydispEvolution_ArchiveFunctionsMenu, 1, en_US]

Figure 4-135 Archive Functions Menu

Get All Data

[sc_ReydispEvolution_GetAllDataIcon, 1, --_--]

Figure 4-136 Get All Data Icon

This reads all the information from the device and stores it to disk. Reydisp will save all the data into a
directory in individual files. After a download the user can open the files to examine them in the same way as
manually saved files. The files are named as follows:
File Type Description
ActiveGrp.txt File containing which is the active group
DataRecd.txt File containing the Data records, includes Fault

records
Events.txt File containing the events
Log.txt Log file stating result of the get all command, which

data was available etc
SetGrpXX.set File containing the settings, where XX is the number

of the setting group
RecordXX.dat File containing the waveform record, where XX is the

number of the record, lowest number is the newest
SysInfo.txt File containing the system information
USER\aaaa A sub-folder containing any user files found in the

device, named as they are in the device

A dialog box is displayed for the user to choose a directory to save the files. The current path is shown at the
top of the box. Underneath is a control to select the target disk drive, then a list of the directories available on
that drive. Double click on a name in the list to enter a sub-directory. If necessary you can create a directory by
typing a name into the control in the Create Directory area and pressing Create.
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[sc_ReydispEvolution_GetAllDataDialog, 1, --_--]

Figure 4-137 Get All Data Dialog Box

Send Archived Settings

[sc_ReydispEvolution_SendArchivedSettingsIcon, 1, --_--]

Figure 4-138 Send Archived Settings Icon

This command is used to send settings files obtained using the Get All Data command back to a device. Select
the folder containing the files, the dialog box shown in Figure 4-139is displayed.
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[sc_ReydispEvolution_SendArchivedSettingsDialog, 1, --_--]

Figure 4-139 Send Archived Settings Dialog

You can use the up ↑ and down ↓ buttons to move files to different groups. Check the settings groups to
send. For convenience All and None buttons are provided. Then press Send to send the files. A message will
be shown to confirm each has been sent correctly.
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Communications

[sc_ReydispEvolution_CommunicationsMenu, 1, en_US]

Figure 4-140 Communications Menu

Clear

[sc_ReydispEvolution_CommsClearIcon, 1, --_--]

Figure 4-141 Clear Icon

This clears the Communications Interface between the device and Reydisp Evolution. Any pending data held in
the device will be lost.

Synchronise

[sc_ReydispEvolution_SynchroniseIcon, 1, --_--]

Figure 4-142 Synchronise Icon

This synchronises communications between the device and Reydisp Evolution. Any pending data held in the
device will be preserved after synchronisation.
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Options Menu
The Options menu can be viewed from the top menu bar and has the following options:

• Button Bar

• Evolution

• Open Application Settings Folder

[sc_ReydispEvolution_OptionsMenu, 1, en_US]

Figure 4-143 Options Menu

Button Bar

[sc_ReydispEvolution_ButtonBarIcon, 1, --_--]

Figure 4-144 Button Bar Icon

This dialogue is used to configure the button bar which runs beneath the menu in the main window. Any
menu command can be added to the button bar, limited only by the width of the screen. The Current toolbar
buttons list shows the present configuration of the button bar, including those buttons unassigned. The
Available toolbar buttons list shows the commands which can be added.
To set a button, select an unassigned button, or a button you wish to replace in the Current toolbar buttons
list, then select a new command from the Available toolbar buttons list and click Set.
To remove a button without assigning an alternate command, select it in the Current toolbar buttons list and
then click Clear.

4.5
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[sc_ReydispEvolution_ButtonBarDialog, 1, en_US]

Figure 4-145 Button Bar Dialog Box

Evolution

[sc_ReydispEvolution_EvolutionIcon, 1, --_--]

Figure 4-146 Evolution Icon

This dialogue sets the general options of Reydisp Evolution.

[sc_ReydispEvolution_EvolutionDialog, 1, en_US]

Figure 4-147 Evolution Dialog Box
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• Confirmation – The confirmation options allow the user to confirm actions before they take place.
The Relay State Change option is always set for security, therefore that an act which changes the state
of the device, for example, changing settings or setting group, or closing an output relay will always be
confirmed.
The first three options are used when communicating with a device, the next three when handling data
downloaded from a device, and the last four are for ease of use of the Reydisp Evolution application.
When set the confirmation is active.

Table 4-2 Confirmation Options

Field Description
Relay State Change Confirm actions which change the state of the device.
Relay Requests Confirm command actions to the device, e.g. trigger

storage
Actions Completed Devices confirm the success of a command
Save Data Confirm save waveform data before closing the

window
Save Settings Confirm save settings data before closing the Settings

editor
Save Information Confirm save other information, e.g. events
Remote View Confirm before removing a waveform data view
Lose CHanges Confirm before cancelling (or closing) a dialogue box
Clear Spont. Events Confirm before clearing the spontaneous events

window
Exit Reydisp Confirm before exiting Reydisp Evolution

Table 4-3 Options

Field Description
Single Line Wheel Scroll This option only applies when viewing the signals

display. With this option turned on, using the mouse
wheel to scroll will only scroll one line rather than the
number of lines set in Windows for the mouse wheel.

Setting Relationships Reydisp Evolution displays settings based on their
relationship to one another. For example, changing
a setting to OFF would hide the settings with a rela-
tionship to this one, switching it ON would again
reveal these settings. This only applies to devices
which define settings relationships. When this option
is cleared all settings are always shown.

Print Settings In Monochrome When this option is turned on the settings tree
printout is in monchrome rather than color.

Auto Sort Spontaneous Events Sorts the spontaneous events window list by time.
Toggling this option off and the list is sorted by
arrival, which is faster. Note, this option only takes
effect on opening a new window. Changing it will not
affect a window already open.
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• Settings Colours – These colors are used by the settings editor when displaying settings, for example:

[sc_ReydispEvolution_SettingsColors, 1, --_--]

Figure 4-148 Settings Colours Example

Table 4-4 Settings Colours

Color Description
Black The color in which the settings are normally

displayed.
Green The color in which the filed of the setting is displayed.
Blue The color in which settings which have been changed

are displayed.
Red The color in which settings are marked for the user's

attention.
Orange The color in which changes in a setting's range are

marked for the user's attention.

• Back Drop – There is a dropdown list and a checkbox that can be changed as explained in Table 4-5.
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Table 4-5 Backdrop Options

Field Description
Dropdown list This list enables the user to choose the background

image displayed on the main window.
Tiled How the backdrop image is displayed, tiled or not.

Open Application Settings Folder

[sc_ReydispEvolution_OpenApplicationSettingsFolderIcon, 1, --_--]

Figure 4-149 Open Application Settings Folder Icon

Open the folder containing the Application settings. This folder also contains the folder where waveforms
saved during monitoring sessions are saved. The location of the folder will be of one of 2 following forms:
C:\Documents and Settings\Your User Name\Application Data\ReyEvo32
C:\Program Files\Reyrolle Protection\Reydisp Evolution 32
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Window Menu
The Window menu can be viewed from the top menu bar and has the following options:

• Cascade

• Tile Horizontal

• Tile Vertical

• Arrange Icons

[sc_ReydispEvolution_WindowMenu, 1, en_US]

Figure 4-150 Window Menu

All open child windows of the main display are listed at the end of this menu, an example can be seen in
Figure 4-150.

Cascade

[sc_ReydispEvolution_CascadeIcon, 1, --_--]

Figure 4-151 Cascade Icon

This option performs the standard windows Cascade function.

Tile Horizontal

[sc_ReydispEvolution_TileHorizontalIcon, 1, --_--]

Figure 4-152 Tile Horizontal Icon

This option performs the standard windows Tile Horizontal function.

4.6
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Tile Vertical

[sc_ReydispEvolution_TileVerticalIcon, 1, --_--]

Figure 4-153 Tile Vertical Icon

This option performs the standard windows Tile Vertical function.

Arrange Icons

[sc_ReydispEvolution_ArrangeIconsIcon, 1, --_--]

Figure 4-154 Arrange Icons Icon

This option performs the standard windows Arrange Icons function.
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Help Menu
The Help menu can be viewed from the top menu bar and has the following options:

• Contents

• How To Use Help

• Help For Active Window

• Reyrolle On The Web

• Support (email)

• Open Relay LED Template

• Open Version History

• About

• Disclaimer

[sc_ReydispEvolution_HelpMenu, 1, en_US]

Figure 4-155 Help Menu

Contents

[sc_ReydispEvolution_ContentsIcon, 1, --_--]

Figure 4-156 Contents Icon

This option opens the help menu at the contents page.
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How To Use Help

[sc_ReydispEvolution_HowToUseHelpIcon, 1, --_--]

Figure 4-157 How To Use Help Icon

This selection opens the How to use the Windows help system tutorial.

Help For Active Window

[sc_ReydispEvolution_HelpForActiveWindowIcon, 1, --_--]

Figure 4-158 Help For Active Window Icon

Selecting this will open help for the active window, for example the Settings editor or Events windows. This
help can also be obtained by pressing the F1 key.

Reyrolle On The Web

[sc_ReydispEvolution_ReyrolleOnTheWebIcon, 1, --_--]

Figure 4-159 Reyrolle On The Web Icon

Selecting this will open the Reyrolle website in your browser.

Support (email)

[sc_ReydispEvolution_SupportIcon, 1, --_--]

Figure 4-160 Support (email) Icon

This will open a blank email to request technical support.

Open Relay LED Template

[sc_ReydispEvolution_OpenRelayLEDTemplateIcon, 1, --_--]

Figure 4-161 Open Relay LED Template Icon

This opens a sub menu containing templates to create slip in labels for device fascias. Requires Microsoft Word
(not supplied).

[sc_ReydispEvolution_OpenRelayLEDTemplateExample, 1, --_--]

Figure 4-162 Open Relay LED Template Example

Command Reference
4.7 Help Menu

130 Reydisp Evolution 32, Software, Manual
C53000-H7050-C032-1, Edition 03.2023



Open Version History

[sc_ReydispEvolution_OpenVersionHistoryIcon, 1, --_--]

Figure 4-163 Open Version History Icon

Choosing this will open Reydisp Evolution's Version History file. Requires Adobe Acrobat Reader
(Not Supplied).

About

[sc_ReydispEvolution_AboutIcon, 1, --_--]

Figure 4-164 About Icon

This will display the version information of Reydisp Evolution. Press the Info button to display a list of
information about the PC and operating system running Reydisp.

Disclaimer

[sc_ReydispEvolution_DisclaimerIcon, 1, --_--]

Figure 4-165 Disclaimer Icon

This displays the software Disclaimer.
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System Information

[sc_ReydispEvolution_SystemInformation, 1, --_--]

Figure 5-1 System Information Dialog Box

This displays useful System Information about your computer and Reydisp Evolution.
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Action On Dialogue

[sc_ReydispEvolution_ActionOnDialogue, 1, --_--]

Figure 5-2 Action On Dialogue Dialog Box

This dialogue selects what you wish to perform the action (e.g. Copy or Save) on.

Table 5-1 Action On Dialogue Options

Option Description
Selected Text Only Perform the action on the selected text only
Complete Document Perform the action on all the text
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Save Real Values Dialogue

[sc_ReydispEvolution_SaveRealValuesDialogue, 1, --_--]

Figure 5-3 Save Real Values Dialogue Dialog Box

When saving the Data Values as ASCII text this dialogue lets you chose which items to include.

Table 5-2 Data Values

Data Description
Include Titles Include a title line as first line of the file
Include Sample No. Include the sample number for each sample
Include Time Include the time stamp for each sample
Include Analogues Include the Analogue Data Channels
Include Digitals Include the Digital Data Channels
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Select Setting List

[sc_ReydispEvolution_SelectSettingList, 1, en_US]

Figure 5-4 Select Setting List Dialog Box

When a setting is a bit mask this list displays the options that can be changed. Check or clear the box next to
each option to change the state.

ii NOTE
In some cases some states may be greyed out signifying they can't be changed.

When finished click OK to keep the changes or otherwise Cancel.
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Select Which Item

[sc_ReydispEvolution_ActivateSettingsGroupDialog, 1, en_US]

Figure 5-5 Select Which Item Dialog Box

This is a dialog box displayed when the user needs to select an item. Click the number of the item or Cancel.
An example of this box is shown in Figure 5-5.
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Rename

[sc_ReydispEvolution_Rename, 1, --_--]

Figure 5-6 Rename Dialog Box

This is a dialog box used to rename a file in the File Manager window.
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Select Viewer

[sc_ReydispEvolution_SelectViewer, 1, --_--]

Figure 5-7 Select Viewer Example

This dialog box is used to select a waveform viewer to use to display a waveform record loaded from a file.
This viewer will be used instead of the any view settings stored in the file or the default settings for the type of
record. After selecting a viewer the standard file open dialog box is displayed. If the user chooses a file other
than a waveform record the viewer settings will have no effect.
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Select Record

[sc_ReydispEvolution_SelectRecord, 1, en_US]

Figure 5-8 Select Record Example

When the user selects the Get Waveform Record command this dialog box is used to select a waveform to
download.
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RS232 Cable Wiring
Table 5-3 shows the wiring connections for a 9 pin female to 25 pin male RS232 cable. This type of cable is
used to connect the 9 way RS232 port on a computer (PC) to the 25 way port of an interface device or older
Reyrolle device.

Table 5-3 Wiring Connections

9 Pin D Type Female 25 Pin D Type Male
1 8
2 3
3 2
4 20
5 7
6 6
7 4
8 5
9 22
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Command Line Parameters
The following parameters are used to configure Reydisp from the command line. These would usually be used
when Reydisp is being used in conjunction with a control system.

Hide Settings change commands /H
Optionally hide the commands that allow the user to change settings in a device, preventing the settings from
being changed.
Options Description
0 Hide commands
1 Show commands

Example: /H:0

Set Address /A
Set the initial device address.
Options Description
1 to 254 Device address

Example: /A:5

Open File
Open the named file on start-up.
Options Description
<filename> Name of file to open on start-up

Example: DCD1PS.DAT

Protocol Library to load on start-up /L
Specify which protocol library to load on start-up, overriding any default set in the application.
Options Description
Rey200_32.dll Sat 200 driver
ReyIec32.dll Serial Port driver
ReySock32.dll TCP/IP driver

Example: /L:Rey200_32.dll

Communication Parameter /P (Dependant on driver loaded with /L)
Specify options for the protocol loaded with /L.

• Rey200_32.dll
Format: /P:<Host Address 1,Host Address 2:Port,Line Selector>
or
/P:<Host Address:Port,Line Selector>

Options Description
Host Address An IP address in the standard form 1.2.3.4
Port The socket port number being used e.g. 2000
Line Selector The line selector, in the range 0 to 255

Examples: /P:10.5.5.255,10.1.1.32:2402,1 /P:10.5.5.255:2402,1
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• ReyIec32.dll
Format: /P:<Com Port:Baud Rate,Parity,Data Bits,StopBits>

Options Description
Com Port Any valid com port fitted to the PC, e.g. COM3
Baud Rate Any Valid Baud Rate e.g. 38400
Parity Parity where e=even, o=odd, n=none
Data Bits 7 or 8
Stop Bits 1 or 2

Example: /P:COM1:19200,n,8,1

• ReySock32.dll
Format: /P:<Host Address:Port,Connection Mode>

Options Description
Host Address An IP address in the standard form 1.2.3.4
Port The socket port number being used e.g. 2000
Connection Mode UDP or TCP. Options #u = UDP, #t = TCP.

Example: /P:10.5.5.255:50000,#u
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Comtrade Export Dialogue

[sc_ReydispEvolution_ComtradeExportDialogue, 1, --_--]

Figure 5-9 Comtrade Export Dialogue Example

The box is displayed when the user chooses to save a waveform record as a Comtrade file set.
The revision year of the Comtrade standard and the format of the data file can be selected.
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Create Signals Wizard
Introduction

[sc_ReydispEvolution_CreateSignalsWizardIntroduction, 1, en_US]

Figure 5-10 Create Signals Wizard Introduction

This page is just the title page of the wizard, click Next to continue.
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Select Function

[sc_ReydispEvolution_CreateSignalsWizardSelectFunction, 1, en_US]

Figure 5-11 Create Signals Wizard Select Function

The user should select the function they wish to apply from the list on the left, click Next to continue.
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Select Signal(s)

[sc_ReydispEvolution_CreateSignalsWizardSelectSignals, 1, en_US]

Figure 5-12 Create Signals Wizard Select Signal(s)

The user can then select the signal(s) they wish to apply the function to from the list, click Next to continue.
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Name Signal

[sc_ReydispEvolution_CreateSignalsWizardNameSignal, 1, en_US]

Figure 5-13 Create Signals Wizard Name Signal

Enter a name for the new signal, click Next to continue.
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Confirm

[sc_ReydispEvolution_CreateSignalsWizardConfirm, 1, en_US]

Figure 5-14 Create Signals Wizard Confirm

Confirm creation of the signal. Press Back to change any parameters, or click Next to continue.
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Finish

[sc_ReydispEvolution_CreateSignalsWizardFinish, 1, en_US]

Figure 5-15 Create Signals Wizard Finish

Click Finish to exit the wizard.
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Save Settings As XML

[sc_ReydispEvolution_SaveSettingsAsXML, 1, --_--]

Figure 5-16 Save Settings As XML Dialog Box

The box is displayed when the user chooses to save settings as an XML file.
Options are available to include a style sheet reference and name it. The Include Full Range option expands
the short description equation into a full range list.
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