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[ Notes ]

(1)No part of this manual may be reproduced in any form without prior permission of the  publisher.

(2)The contents of this manual, including the specifications, are subject to change for improvement without

notice.

(3)This manual was prepared with utmost care.  However, if you find any ambiguity, errors, etc., please

contact any of our sales offices that are listed at the end of this manual.  In so ding, please tell the manual

number shown on the cover of this manual.

Preface
Thank you very much for purchasing the Fuji UG Series UG00P-MS(Memory Card Editor).

This  manual explains how to operate UG00P-MS when writing from a PC to a SRAM/CF card, or reading the
data from a SRAM/CF card to a PC.

This manual is constructed under the condition that the user would understand all the functions of memory
manager, data logging, SRAM cassette/built-in SRAM, and CF card in POD UG series very well.
About these functions, refer to the User’s Manual <Function> (FEH376).

[Reference]
In addition to this manual, the following manuals on the UG Series are available.  Please ask your nearest
dealer for the appropriate manuals and read them as required.

About Trademarks

• Windows, Word and Excel are registered trademarks of Microsoft Corporation in the United States and

other countries.

• All other company names or product names are trademarks or registered trademarks of their respective

holders.

• Programmable logic controllers (PLCs) are products of their respective manufacturers.

Name Manual No. Contents

UG Series Manual      FEH375 Describes the operations available with the
<Operation> UG Series.

UG Series Manual      FEH376 Describes the functions available with the
<Function> UG Series.

UG20 Series Manual      FEH352 Describes the UG20 Sereis hardware
<Hardware> specifications.

UG30 Series Manual      FEH377 Describes the UG30 Sereis hardware
<Hardware> specifications.

UG230 Series Manual      FEH381 Describes the UG230 Sereis hardware
<Hardware> specifications.
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Outline

Data is transferred between the PLC and the memory card with two UG30/20 series

SRAM/CF card functions: memory manager and data logging.

Memory Card Editor is software that allows the user to write data that was entered and

edited on a personal computer onto the SRAM/CF card, and also acts as conversion

software that reads data saved on the SRAM/CF card and makes it possible for this data

to be edited by spreadsheet software etc.  The converted data becomes comma (,)

delimited CSV data.

Data from Memory Manager
The parameters for machine temperature, pressure, conveyor speed, etc., are allocated

in each machine's individual memory card internal record.

Record names and numerical data within records can be edited with Memory Card

Editor as well as with spreadsheet (e.g. Excel).

As the amount of record data to be edited becomes larger and larger, you may find that

it is easier to perform editing using application software that you are accustomed to,

and then transferring the data to Memory Card Editor.

Outline
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Data from Data Logging
It is possible to read data accumulated from constant sampling, bit synchronization, bit

sampling, alarm display, and temperature control network PLC2Way from the SRAM/

CF card, change this data into a graph using spreadsheet software (e.g. Excel), and edit

and manage this software as a product document.

RESET

disc

POWER
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SYSTEM

Personal computer
POWER

POD

Trend Sampling

Format

Data Logging Function
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CF card

Memory Card Editor

- - - - - 
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- - - - -

RUN

STOP

PLC

CF Card Supported (UG00P-MS Ver. 2.0.0.0 or later, UG30 only)
* Check that the UG30 has the system program version 1.080 or later.

Access to UG320HD (handy type) is not supported.

In the UG30 series, a CF card interface is implemented as standard.  For the functions

used for a CF card, you need to store the data to the CF card, or import the data in the

CF card to a PC.  However, in case that your PC does not support the CF card, or that it

is difficult to insert/remove the CF card from the UG30, "Memory Card Editor" allows

you to read/write the CF card while the CF card is inserted into the UG30 series.
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Outline
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Outline

SRAM Cassette/ Built-in SRAM Supported
(UG00P-MS Ver. 2.0.0.0 or later)

* Check that the UG20 has the system program version 1.200 or later.

The UG30 and UG20 series are supported for SRAM cassette/ built-in SRAM.  For the

functions used in these SRAM areas, you need to store the data to the SRAM, or import

the data in the SRAM to a PC.

In the previous version, only reading/writing of "Memory Card Emulation Area" in the

SRAM area was supported.  From Ver. 2.0.0.0, in addition to "Memory Card Emulation

Area," the data of "Memo Pad" or "Non-volatile Memory" can be read/written.

UG00C-T

Memory Card Editor 
UG00P-MS

POWER

F1

F2

F3

F4

F5

F6

F7

SYSTEM

UG30

SRAM cassette
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Cable for Ethernet
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Memory Card 
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Storage Area 
for Memo Pad 

Non-volatile Memory 
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Non-volatile Memory 
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Personal computer

Ethernet Communication Supported
* Check that the UG20 has the system program version 1.200 or later.

Check that the UG30 has the system program version 1.080 or later

when you wish to access a CF card.

Data transfer by Ethernet communication is supported.  If there is a POD system

(UG30/20 series) and a PC with the memory card editor installed, high speed data

reading/writing on the LAN will be possible.  You can check logging data or recipe

data, which are on a POD in a remote production site, from your office.

96
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B

CompactFlash Card

Memory Card Editor 
UG00P-MS

POWER
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F2

F3

F4

F5

F6

F7

SYSTEM
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etc.

Factory

Office
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Connecting to a PC

Connecting to a PC

The following shows the connection configuration when SRAM/CF card data created

on the POD is read to "Memory Card Editor," or data edited on a PC is written to the

SRAM/CF card via "Memory Card Editor."

Connecting to a Recorder

UG00P-MR

Personal computer

Memory card

UG00P-MR

AC adaptor

UG00C-T

Connect to the serial port

RESET

disc

Memory Card Editor 
UG00P-MS

CF Card Reader/Writer

C F R M

96MB

RESET

disc

CF card

CF card reader/writer

Memory Card Editor 
UG00P-MS
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Personal computer
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Connecting to a PC

Connecting to a POD

UG30 Series (UG00C-T Connection)
* Check that the UG30 has the system program version 1.080 or later

when you access a CF card.

UG30 Series (Ethernet Connection)
* Check that the UG30 has the system program version 1.080 or later

when you access a CF card.

In the UG30 series, the connection for "UG30(high-performance type)" and

"UG30(standard type)" are different.  For "UG30(high-performance type)," you can

connect to the LAN directly because it has a built-in LAN port.  However, for

"UG30(standard type)," you need an additional I/F unit "UG03I-E (2)."

UG00P-MR
cable

Memory card

UG00P-MR

To MJ2 (MJ1)

POWER
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SYSTEM
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UG30
(high-performance)
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Cable for Ethernet

Cable for Ethernet
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UG03I-E(2) To UG03I-E(2)
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UG20 Series (UG00C-T Connection)
* Check that the UG20 has the system program version 1.180 or later.

Note that UG320HD (handy type) is not supported.

Connecting to a PC

UG00P-MR
cable

Personal computerUG00C-T

Memory Card Editor 
UG00P-MS

Main Menu

Memory card

UG00P-MR

To MJ2 To MJ1

UG00C-T

To MJ1

Personal computer

Memory card

Memory Card Editor 
UG00P-MS

Main Menu

SRAM cassette 

C
N

1

P02172-2
V6-MCB

or

UG00P-MR

Built-in SRAM card interface or SRAM cassette

UG20 Series (Ethernet Connection)
* Check that the UG20 has the system program version 1.200 or later.

Memory card

LAN

Cable for Ethernet

Personal computer

Memory Card Editor 
UG00P-MS

UG03I-E(2)

UG00P-MR
cable

Memory card

UG00P-MR

To MJ1 
or MJ2 or

C
N

1

P02172-2
V6-MCB

SRAM cassette To UG03I-E (2)
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Memory Card Editor Notes

When a memory card or CF card is removed or canceled while data is being written to

it, the data on that card cannot be guaranteed.

Even if the memory card or CF card is read normally, take into account the fact that the

data that is read is inaccurate.

Memory Card Editor Notes

Memory Card Editor Operating Procedures

When you start the memory card editor, the following screen is displayed.

Before starting an operation, make sure what target is to be read/written using the

Memory Card Editor.  Depending on the target, menu commands selected from the

[File] menu will vary.

A

B

C

D

E
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A. Memory Card

This menu is for the data stored in the UG00P-MR (UG30/20 series),

orbuilt-in memory card type (UG20 series)  .

Refer to page 9.

B. CF Card

This menu is for the data stored on a CF card (UG30/UG320HD).

Refer to page 45.

C. SRAM

This menu is for the data stored on a SRAM cassette or the built-in SRAM

(UG30 series).

Refer to page 60.

D. Communication Settings

For serial communication (when using UG00C-T), specify the baud rate and

the serial port.  For Ethernet communication, set the IP address.

E. Use Ethernet

Check this menu when you read/write the data via Ethernet communication.

"A. Memory Card"  Refer to page 41.

"B. CF Card"  Refer to page 46.

"C. SRAM"  Refer to page 60.

Memory Card Editor Notes
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[Memory Card]

Usable Memory Cards
An SRAM card or FPROM card can be used for the memory card.  The following

table shows the difference between the SRAM card and FPROM card:

The following memory cards supplied from Fuji Electric Co.,Ltd. are recommended.

SRAM

UG00K-S25K(256K) UG00K-S02M(2M)

UG00K-S51K(512K) UG00K-S04M(4M)

UG00K-S01M(1M)

FROM

UG00K-F25K(256K) UG00K-F01M(1M)

UG00K-F51K(512K) UG00K-F02M(2M)

[Memory Card]

* The FROM card cannot support any functions of memory manager and data logging.

SRAM FROM

Supports the functions of POD memory 
manager and data logging, and transmission 
of screen data.

Data is partially readable and writable at any 
time.

Supports transmission of screen data.

Data is written and read all together.  
Data cannot be written or read partially.

Contains a battery.  Replace the battery when 
it runs out.

No battery replacement is required.
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RESET

disc

MCD
File

file 0

file 1

file 2

file 15

Memory card

(1) Start Memory Card Editor.

(3) Read the data from the card.
      (Memory card data file [.mcd])

  File  0

  File  1

  File  2

  File  3

  File  4

  File  5

  File  14

  File  15

(2) Connect the UG00P-MR 
      or UG30/20 to a PC.

UG00P-MR

Memory Card Editor 
UG00P-MS

1)  Before Connecting Memory card to a PC
1. Start Memory Card Editor.

2. Set the communication port and baud rate for communicating with a UG00P-MR or

UG30/20 with a built-in card.  Go to [File], click on [Communication Settings], and

set the [Communication Detail] dialog.

Reading from the Memory Card
Use the data logging or memory manager function to read data stored in the memory

card to a personal computer.

Operation Outline
The read procedure is as follows.

[Memory Card]

The information read from the memory

card is read to the PC as a memory card

data file.  The extension when saving on

the personal computer is [.mcd].  From

now on, a memory card data file will be

referred to as an MCD file.
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The messages "Accessing memory card" and "Receiving from the memory card" are

displayed.  When reading of the memory card is complete, the [Memory Card

Information] window is displayed.

[Memory Card]

2)  Connect UG00P-MR or UG30/20 with a Built-in Card
Interface to the PC

Use a UG00C-T (RS232C cable for screen data transmission) to connect a personal

computer to a UG00P-MR (with an AC adapter) that has a memory card inserted in it,

or to UG30/20 with a built-in card interface that has a memory card inserted in it.

3)  Read from the Memory Card
Click the [Read Memory Card] icon, or select [Read from the Memory Card] from

[Memory Card] under the [File] menu.

Clicking the [Read Memory

Card] icon enables to read

all the contents of a

memory card.

or



12

Memory Card
Information

Size

File size = (Bytes for Records + No. of Data × 2) × No. of Records

File size = (No. of Words X 2 + 4) X No. of Samples

File size = 6 X No. of Samples

File size 
= (No. of Words × 2 + 4) × No. of Samples 

2048

Data File

Bit Synchronize

Constant 
Sample

Bit Sample

B
uf

fe
rin

g 
F

ile

(Unit: bytes)

1) Memory card information always uses the byte amount shown above from the memory card 
    top memory address.
2) [No. of Words] is the number of the words used for memory in the [Temp. Network/PLC2Way 
    Table [No.]] set in [No. of Table].

1)

Alarm Function File size 
= 6 × No. of Samples + 30 + No. of Words × 16 × 6 × 2 

Temp. Control Net.
/PLC2

File size 
= (No. of Words × 2 + 4) × No. of Samples 

2)

Card name and

card number

Model name

Size

When card is selected, the entire memory card size is displayed.  When file is

selected, the file size is displayed (units: MB/kB/bytes).

(1kB = 1024 bytes)

 [Memory Card Information] Window

Items such as the model and data size are displayed in the [Memory Card Information]

window.

 Calculation of File Size

The various file sizes are shown.

[Memory Card]
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To check more detailed contents, click the [Data File Edit] icon with the file selected,

or double-click on a file.  The file's data will be displayed in chart form.

Depending on the file's type, the contents of the displayed data edit window will vary

somewhat.

For example, if file0 is clicked...
the amount of records and record names

are displayed.

For example, if file0 is double-clicked... the data edit window is displayed.

Checking and Editing File Contents
Each file's complete data is contained within the contents read from the memory card.

When a you click on a file folder on the [Memory Card Information] window, the

record names and sampling forms for that file are displayed on the right.

[Data File Edit] icon

[Memory Card]
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Record number

Data number

Record name

[Type: Data]

[Type: Sampling Buffer]

 [Sampling Method: Bit Synchronize] or [Constant Sampling]

No. of  Samples (counts)

Clock data Data number

How to Change the Display Direction of the Chart Form in a Data File
The vertical display of a data file can be changed to the

horizontal display.  Also, the horizontal display can be

changed to the vertical display.

Click [Change Display Layout] in the [View] menu with the

Data edit window opened.

The display is changed with the direction reversed.

[Memory Card]
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Follow the procedure below to import messages that are the same as those messages

displayed.

1. When the data edit window is open, go to [File] and click on [Open Reference

Screen Data...].

2. A file specification window like the one below is displayed.  Select the original

screen data file and click [Open].

3. Messages applicable to each respective relay number are displayed in the [Message]

column of the data edit window.
The corresponding messages are imported.

No. of Samples (counts)

Bit status Clock data

 [Sampling Method: Bit Sampling]

The default status for bit ON/OFF, clock, and relay number is as shown below.  The

message column is empty.

Relay number Messages

[Memory Card]
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The messages for the last file referenced are read.  Be sure to reference

the original screen data file each time.  If different screen data is

referenced, it is impossible to import the correct messages.

Changing the Time Display

A [Type: Sampling Buffer] data file always

includes a time display.

Default display status is [MM/DD hh: mm:

ss], but the display type can be changed

freely.

When the sampling buffer data edit window is open, go to [View] and click [Options].

A [Display Type] dialog like the one following is displayed.  For example, select [MM-DD

hh:mm:ss] and click [OK].

The data edit window time display changes as shown below.

[Memory Card]
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 [Sampling Method: Alarm Function]

The default status for bit ON/OFF (=Occurrence/Cancellation), clock, relay number and

message is shown below.

If the message is not shown, read the messages by referring to [Sampling Method: Bit

Sampling].  When referring to the screen data, the setting of [Display Way Setting] in

the [View] menu (see the next page) is automatically specified according to the setting

of the screen data.

No. of Samples

 (Counts)

1. When checking the first cause, click [Display Information of First Cause] in the

[View] menu. (Refer to the left menu.)  The comment "First Cause" shows that it is

the first cause as shown below.

2. When displaying the operating status, click [Display Operate Status] in the [View]

menu.  Each condition is displayed on the [Operation Condition] dialog as follows.

Bit status          Clock data    Relay number Messages

[Memory Card]



18

3. When displaying the same data as the one in UG30/20, click [Display Way Setting]

in the [View] menu.  The [Display Way of Alarm Function] dialog is displayed.

Check [Display by the Specified Way].  The setting items for selection are displayed

as follows.

When setting these items as same as in UG30/20, the same display is shown in this

editor.

Example for setting as follows

Display Mode Cancellation

Calendar Condition Date and Time

Data Display MM/DD

Time Display hh:mm:ss

Display Order Chronological Order

About [Display Mark for First Cause], in UG30/20, "*" shows the first cause.  In

UG00P-MS, the characters, "First Cause," shows the first cause.

[Memory Card]
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When displaying the messages deleted by the switch [Function: DEL] in UG30/20,

check [Display the Deleted Alarm].

The message deleted by the

[DEL] switch is displayed.

Clock data

When unchecking [Display by the Specified Way], the default condition is

displayed.  (Refer to upper page 17.)

 [Sampling Method: Temp. CTRL/PLC2]

Data No. used in [Temp. CTRL Network Table [No.]]

specified in [Table No.] of [Buffering Area Setting]

No. of Samples (Counts)

[Memory Card]
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When the changed record name is not reflected in the [Memory Card Information]

window, go to [View] and then click on [Update to Newest Data], and the record name

that was changed will be displayed.

When "1234" is entered and the return key is pressed, data 1025 becomes "1234."

Data File Edit

Changing Data
With the Memory Card Editor, it is possible to change data read from the memory card.

Data edit is only possible for a [Type: Data] file (memory manager

function).  A contents of a [Type: Sampling Buffer] file (data logging

function) cannot be changed.

Changing the Data Value/Record Name

When you double-click on the column that you wish to change in the previously opened

edit window, the cursor moves to the left corner.

When new information is entered with the keyboard, the contents of the column are

altered.

When you double-click on data 1025 of record 0, the highlight display moves to the left.

Change record name.

Not reflected here.

[Memory Card]
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To change the format of one column, use the cursor to select the column to change, go

to [Edit], and click [Data Format].

For [Type: CHAR

(characters)], set

the number of

characters.

Items such as [Type] are changed in the same way as change all.

Other Editing

Cut, copy, paste, and delete operations

These operations can be performed easily by selecting the applicable column with

the cursor (multiple selections possible), and then going to the [Edit] menu, or by

using the right-click menu and then clicking on the desired edit contents.

Changing the Data Display Form

It is possible to change each column's display type by all, one column, or multiple

columns.

To change all, go to [Edit] and click [All Data Format Settings].  When the [Data

Format] dialog is displayed, set [Characters], [Decimal Point], and [Words].

Return to undo/redo edit operations

To erase the most recently performed edit operation, click [Undo].  To re-execute an

operation that was erased, click [Redo].

[Memory Card]
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Copying Data Format
The data format specified in the previous setting, "  Changing the Data Display

Form," can be copied to other file.

The following files can be copied.

Select the file on the [Memory Card Information] window.

Click [Copy Data Format] in the [Edit] menu.

Select the file to format, and click [Paste Data Format] in the [Edit] menu.

Data

Sampling Buffer

Constant Sample

Bit Synchronize

Bit Sample

Alarm Function

Temp. Control Net.

[Memory Card]
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or

or

Jump Function on Data Edit Sheet
In a data edit sheet, up to 128 data can be displayed on each line/column per one page.

If there are some pages in one sheet because of large file size, any page can be

displayed quickly by using jump function.

Click the [Jump] icon or [Jump] in the [View] menu.  The [Page No] dialog is

displayed.  Input the page number to be edited.

[Memory Card]

Changing Row Height and Column Width
To change the cell height or width, move the mouse to the boundary line as shown in

the diagram to the right, and then drag the cursor until you reach the desired height/

width.

To return to the default height/width, click the [Standardize Cell Size] icon, or go to

[View] and click [Standardize Cell Size].
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3)  Select a number from the list box and click the [Setting] button.

4)  The characters are set for the specified number.

5)  To confirm, click the [OK] button.  The title is set.

To cancel, click the [Cancel] button.

• Multiple items can be selected by using the Ctrl key or the Shift key.  The titles for

all items selected will be deleted with the [Delete] button.

• It is possible to import titles from comma-delimited text files like a CSV file (e.g.:

TITLE1, TITLE2, TITLE3, TITLE4) by clicking the [From File...] button.

• Clicking the [Copy of Title] button and entering the other file number enables the

title of the file to be copied.

File Save
To save data that has been changed, go to [File]

and click on [Save], or click on [Save As...].

A data file that has been changed is stored

as an MCD file.

<Example> XXXX.mcd

Title Edit
Title edit can be performed for bit synchronization and constant sampling in the data

file and sampling buffer file.

File name Extension

[Memory Card]

Title Edit Procedure

1)  When you go to [Edit] and click on [Title Edit], the [Title Edit] dialog is

displayed.

2)  For [Edit], enter the characters that make up the title name.
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Reading/Writing a File
In case of opening the [Data Edit] window on the Memory Card Editor, only the opened

data file can communicate with a memory card.

[Data edit] window

File Reading
1. Click the [Read File] icon  or [Read File] of [File] menu.

2. Read only the data from the file to be edited.

File Writing
1. Click the [Write File] icon  or [Write File] of [File] menu.

2. Transfer only the file data to be edited to a memory card.

When the edited file is [Type: Sampling Buffer], only reading is available.

Writing is unavailable.

[Read/Write File] icon

[Memory Card]
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2. When you go to [File] and click on [Create CSV File...], a diagram like the one

below is displayed.  Specify a name and click [Save].

  MCD
  File

file 0

file 1

file 2

file 15

CSV
  File 

CSV
  File 

CSV
  File 

CSV
 File 

Any type of the file
including
[Type: Data File]
[Type: Buffering File]

Personal computer

---
---
---
---
---
---

---
---
---
---
---
---

---
---
---
---
---
---

---
---
---
---
---
---

---
---
---
---
---
---

---
---
---
---
---
---

Memory card

1. When you double-click on the desired file from the MCD file directory, the [Data

Edit] window opens.

Double-click on file

Creating and Reading a CSV File

Creating a CSV File
It is possible for each MCD file (both [Type: Data] and [Type: Sampling Buffer]) to be

written separately as CSV files.

[Memory Card]
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[  Make a File in 256-Column Format]

This setting is effective when the data count in a data file is 256 or more.  When

you save the data in a CSV file and edit it with Excel, only 256 columns can be

displayed.  If the data count is 256 or more, you cannot open the CSV file with

Excel.  If you check this item and save the file, the CSV file will be created

automatically from "(the desired file name) ~1.CSV" with the available number

of columns (= data count).

[Data count: 1000] + "Record name" column = 1001 columns

Divided at the 256th column

↓
DATA~1.CSV DATA~2.CSV

DATA~3.CSV

DATA~4.CSV

…

Any file is divided at

the 256th column

[  Give a Title]

Using the memory card editor function, each title in a data file can be edited.

Check this box if you save the title as data when saving in a CSV data.

3.  Specify the file name and click [Save].

The data file currently open is saved as a CSV file.

[Memory Card]



28

Reading from a CSV File
It is possible to read a CSV file into an MCD file.

Reading is possible only for [Type: Data] data files.

([Type: Sampling Buffer] files are write-prohibited files.)

MCD
File

file 0

file 1

file 2

file 15

CSV
  File

CSV
  File

If the contents differ from the one in [Memory Card
Information Properties], data may not be imported
or read normally.
(See note 2 on the next page.)

CSV
  File

[Type: Data File]

[Type: Data File]

[Type: Buffering File]

If the file type is the same as the one in [Memory Card 
Information Properties], data is imported normally.

   [CSV file [Buffering File]
   files are not accepted.

1. When you double-click on the desired file from the MCD file (although this must be

a file of [Type: Data]), the [Data Edit] window opens.

2. When you go to [File] and click on [Read CSV File...], a dialog like the one below is

displayed.

<Note 1>

[Memory Card]
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[  Give a Title]

Using the Memory Card Editor, each title in a data file can be edited.  If you

check this item and import a CSV file, the top line of the CSV file will be

recognized as a title.

3.  Specify the CSV file to be imported and click [Open].

4. The contents of the specified CSV file are written in the data file.  To save the

imported information, save the MCD file using [Save] or [Save As...].

The contents change

If the larger value of the decimal point than the specified value is set in a cell, the

value is ignored.  Also, the larger number of the characters than the specified

number is entered, the number is ignored.

When data format of CSV file to be read is different from the data format

at the import destination, there are instances when the contents of the

CSV data are not read normally.

For example, when you import a CSV file [Type: Sampling Buffer] into the data

file, the data is imported forcibly and inaccurately into [Record Name] and other

data.

<Note 2>

[Memory Card]
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Data Exchange between UG00P-MS and Spreadsheet
(e.g. Excel)
In order to write the data in UG00P-MS to other software such as Excel, or write the

data in Excel to UG00P-MS, it is necessary to convert the data into CSV file.

<e.g.>

To write the data in UG00P-MS to Excel

1) Create and save a CSV file in UG00P-MS by referring to "Creating a CSV File"

previously described.

2) Start Excel, click [Open] from the [File] menu and select [Text Files (*.prn, *.txt,

*.csv)] in [File of Type].

3) Select the file created in step 1) and click [Open].  Excel starts to read the data

from UG00P-MS.

To write the data in Excel to UG00P-MS

1) Click [Save As ...], select [Save as Type:] in [CSV (Comma delimited) (*.csv)],

and save the file in Excel.

2) Start UG00P-MS, and read the data from Excel by referring to "Reading from a

CSV File" previously described.

In addition to the above method, the data can be exchanged by copy and paste

commands.  In this case, the data type is limited similar to the CSV file format.

Refer to <Note 1> and <Note 2> on page 28 to 29.

1) Drag the area to copy on the data file of UG00P-MS, and copy it.

2) Start Excel, and paste the data on Excel.

3) Also, it is possible to copy the data on Excel, and paste it on UG00P-MS.

[Memory Card]
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(4) Write data.

(1) Start Memory Card Editor.

(2) Connect  UG00P-MR or 
      UG30/20 to a personal computer.

  File  0

  File  1

  File  2

  File  3

  File  4

  File  5

  File  14

  File  15

  MCD
   File

file 0

file 1

file 2

file 15

Memory card (3) Open the memory card data file [.mcd].

Writing to the Memory Card
After editing is completed, write the MCD file, which includes the data file, onto the

memory card.

Operation Outline
The write procedure is as shown below.

1)  Before connecting the memory card to a PC
1. Start Memory Card Editor.

2. Set the baud rate for communicating with UG00P-MR or UG30/20 with a built-in

card interface.  Go to [File] and click on [Communication Settings...], and then set

the [Communication Detail] dialog.

[Memory Card]
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When this is done, the MCD file is open.  (The name of the MCD file that is open is

displayed above the editor title bar.)

2)  Connecting UG00P-MR to a PC
Use a UG00C-T (RS232C cable for screen data transmission) to connect a personal

computer to a UG00P-MR (with an AC adapter) with a memory card inserted in it, or to

UG30/20 with a built-in card interface with a memory card inserted in it.

3)  Open an MCD file
Specify the MCD file to be written on the memory card by going to [File], [Memory

Card] and then click [Open].

[Memory Card]
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If the formats agree, a dialog like the one below indicating writing in process is

displayed.

When the dialog disappears, this is an indication that MCD file contents have been

written onto the memory card.

When you click here...

The memory card contents that were copied are displayed.

When you click here, data is written after the

memory card is formatted.

4)  Write data on the memory card
Write MCD file contents onto the memory card.

When the MCD file format is the same as the format of the memory card inserted into

UG00P-MR, writing takes place immediately.

When the format is different, confirm whether or not you wish to format the memory

card and write.

1. Click the [Write Memory Card] icon, or go to [File] and click on [Write to the

Memory Card].

2. When the formats disagree, a window like the one below is displayed.

All the data of MCD

file can be written by

clicking the [Write

Memory Card] icon.

or

[Memory Card]
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Formatting and Copying the Memory Card

Memory Card Formatting
Formatting is performed after opening the MCD file in the editor and formatting the

memory card with the same contents as the MCD file.

However, the MCD file card names, file names, record names, and data contents cannot

be written on the memory card.

1. Connect the UG00P-MR to a personal computer.

2. Insert the memory card to be formatted into the

UG00P-MR.

3. Start Memory Card Editor and open the MCD file.

4. Go to [File] and click on [Memory Card format...].

5. A warning message like the one shown below is

displayed.  When [OK] is clicked, the next dialog is

displayed.

When the dialog disappears, this is an indication that the memory card and the MCD

file are now in the same format.

Memory Card Copying
Copying from one card to another is possible.

As long as they fall within the acceptable current use capacity range, it is possible to

copy between an SRAM card and an SRAM card, an SRAM card and an FROM card,

and an FROM card and an FROM card.

(For example, if only 256k are being used on a card with a 1M capacity, it is possible to

copy on to the 256k card.)

1. Connect the UG00P-MR to a personal

computer.

2. Start Memory Card Editor.

3. Go to [File], [Memory Card] and click on

[Memory Card Copy].

4. A confirmation dialog like the one below is

displayed.  Insert the memory card to be

copied from into the UG00P-MR and click

[OK].

A memory card

which saves the

screen data can

not be copied.

[Memory Card]
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5. After a dialog like the one shown below is displayed, the confirmation dialog will be

displayed again.  This time, insert the memory card that will be copied to into the

UG00P-MR and click [OK].

7. If the capacity of the card that will be copied to is adequate but the format

information varies from the card that is copied from, the following dialog is

displayed.  If you go ahead and click [Write], copy is executed.

6. If the capacity of the card that will be copied to is inadequate, the following message

is displayed and copy is canceled.

Other Setting Items

Checking Memory Card Information
From Editor, it is possible to check the contents of the memory card that is inserted into

the UG00P-MR currently connected to a personal computer.

When you click the [Memory Card Information] icon or go to [File] and click on

[Display Memory Card Information...], the dialog shown below will appear after a few

moments.

Check contents by switching between the tab windows for file numbers 0 to 15.
or

[Memory Card]
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Changing the MCD File Type (Properties)
It is possible to change an MCD file's card name, file name, records, and data, among

other things.

Select a card name or file in the [Memory Card Information] dialog, click the

[Properties] icon, or go to [Edit], and click on [Properties].

The [Memory Card Information Properties] dialog is displayed.

Items like the ones below can be changed on the [0] to [15] tab window.

[Card Name] and [Card Number] can be changed on the [Memory Card] tab window.

After selecting a file,

display the [Memory

Card Information

Properties] with Shift

key + Enter key.

Shortcut

[Properties] icon

[Memory Card]
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Printing
It is possible to print directly from Memory Card Editor.

 [Printer Setting]

When you go to [File] and click [Printer Setting...], a [Print Setup] dialog like the one

below is displayed.

Set printer model, paper size, and paper orientation here.

 [Print]

When you go to [File] and click [Print...], a [Print] dialog like the one below is

displayed.

After you specify the print area and machine settings here and click [OK], printing

takes place.

[Memory Card]
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Set the necessary items.

Creating a New MCD File
It is also possible to create a new MCD file on the editor instead of reading from the

memory card.

1. When you click the [New] icon or go to [File], [Memory Card] and click [New], a

confirmation dialog like the one shown below is displayed.

2. When you click on [Yes] and specify the screen data file that will be used as the

source file, that setting is referenced and the MCD file format is automatically

determined.

3. When you click on [No], the [Edit Model] dialog is displayed.  Select the model to

connect to and click [OK].

4. The [Memory Card Information Properties] dialog is displayed.

Set each setting item and the [Memory Card Information] dialog is displayed.

[Memory Card]

or
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Ethernet Connection
When connecting to the UG30/20 series which supports Ethernet communication, it is

possible to read/write the information in a memory card connected to the UG30/20 via

Ethernet.

Use UG20 system program version 1.200 or later.

Connection between UG30/20 and PC
1. UG30(high-performance type)

Connect the LAN port on the rear side of the UG30 to a PC using the cable for

Ethernet.

UG30(standard type)/UG20

Connect UG03I-E on the rear side of UG30(standard)/UG20 to a PC using the cable

for Ethernet.

2. Start UG00P-MS.

3. Click the [Ethernet Communication] icon, or [Use Ethernet] from [File] menu.

4. Click [Communication Settings] from [File] menu.

The [IP Address Setting] dialog is displayed.

5. Specify the IP address of UG30/20, and click [OK].

[Memory Card]

[Ethernet Communication] icon
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RUN Mode Communication
In case of Ethernet connection, RUN mode communication is available.

RUN mode communication can maintain RUN mode while communicating with a

memory card without displaying the Main Menu (= communication stops).

 Setting

1. When starting RUN mode communication, click the [RUN Mode Communication]

icon, or go to [File], [Memory Card], and then click [RUN Mode Communication].

2. The [Comm. Option] dialog is displayed.

[IP Address]

Specify the IP address of the UG30/20.

[Port No.]

When the port number of UG30/20 is any other than 10000, specify the port

number here.

If RUN mode communication is not selected, this setting is not necessary.

[  UG20 (Version < V1.200)]

Check this box if connecting via Ethernet to a UG20 which has the system

program version 1.200 or earlier.

When the setting is complete, click [OK].

After clicking [OK], if you wish to confirm the settings of the [Comm. Option] dialog again,

click the [Comm. Option] icon.

or

[Memory Card]

[Comm. Option] icon
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 Reading/Writing Memory Card

1. Check if UG30/20 is in RUN mode, and click the [Read/Write Memory Card] icon,

or [Read from the Memory Card/Write to the Memory Card] from [File] menu.

2. Communicate with a memory card.

When clicking the [Write Memory Card] icon, only the data file is written.

The sampling buffer file is not written.

When UG30/20 displays the Main Menu, the following dialog is displayed.

Make UG30/20 in RUN mode, or click [Read from the Memory Card/Write

to the Memory Card] again after stopping RUN mode communication.

[Memory Card]
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 Reading/Writing File

1. Open the [Data Edit] window.

2. Check if UG30/20 is in RUN mode, and click the [Read/Write File] icon, or [Read/

Write File] from [File] menu.

3. Communicate with a memory card.

When connecting via Ethernet, the information of a memory card can be

read or written without using RUN mode communication.  In this case,

the display of POD is automatically switched to the Main Menu while

communicating with a memory card.

Make the [RUN Mode Communication] icon raised ( ).  The way to read/

write the data is the same as in RUN mode communication.

[Memory Card]
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[CF Card]

[CF Card]

Operation Examples

Read from CF Card  Write to CF Card

96
M

B

CompactFlash Card

Memory Card Editor 
UG00P-MS

or

(1) 
Line data 

Factory

Office

C F R M

96MB

CF card

CF card reader/writer

PLC

POWER

F1

F2

F3

F4

F5

F6

F7

SYSTEM

In 
operation

The line data in operation

(1) 
Line data 

(2) Edit the line data to be modified

(3) Write the modified data

(3) Write the modified data

- - - - - 

- - - - -

- - - - -

- - - - -

- - - - - 

- - - - -

- - - - -

- - - - -

- - - - - 

- - - - -

- - - - -

- - - - -

- - - - -

- - - - -

- - - - -

- - - - -

RUN

STOP

(1) Read the line data in operation  (2) Modify the data  (3) Write the modified data

Write Screen Data & CF Card Data to CF Card

96
M

B

CompactFlash Card

Factory

run

stop

PLC

POWER

F1

F2

F3

F4

F5

F6

F7

SYSTEM

In 
operation

Re-write the screen data

(1) Modify the screen data

(2) Write the screen data 
      & the data for CF card

(3) To the production site

C F R M

96MB

RESET

disc

CF card

CF card reader/writer

Memory Card Editor 
UG00P-MS

UG00S-CW

(1) Modify the screen data  (2) Write by UG00P-MS   (3) To the production site
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Reading from a CF Card
1.  Start Memory Card Editor.

2.  When reading the data from the UG30 which has a CF card inserted, set the

communication settings first.  If you access the CF card in a CF card reader/writer

which is connected to a PC, go to step 3.

[CF Card]

96
M

B

CompactFlash Card

Memory Card Editor 
UG00P-MS

or

UG30

C F R M

96MB
CF card

CF card reader/writer

POWER

F1

F2

F3

F4

F5

F6

F7

SYSTEM

When using UG00C-T:

Click [Communication Settings] from the [File] menu.  The [Communication

Detail] dialog is displayed.  Specify [Serial Port] and [Baud Rate] of your PC.

When using Ethernet communication:

1)  Click [Use Ethernet] from the [File] menu.  [Use Ethernet] is checked.

2)  Click [Communication Settings] from the [File] menu.  The [IP Address Setting]

dialog is displayed.  Specify the IP address of the UG30.
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[CF Card]

3.  Click [CF Card] from the [File] menu.

The [Select the Drive of a CF C...] dialog is displayed.

4.  When reading from a CF card reader/writer:

Click the appropriate drive, and then click [OK].

When reading from the UG30 via a UG00C-T:

Click [-COM-], and then click [OK].

When reading from the UG30 via Ethernet:

Click [-Ethernet-], and then click [OK].

5.  For the CF card reader/writer, the contents of the CF card are immediately

displayed.
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6.  When reading data via the UG30, reading process will be started after the message

"Initial checking" is displayed.

Because all the data in the CF card is read, the reading process may take

a long time.

7.  When reading is complete, the window as shown below is displayed.

When the UG30 reads via [COM], [COM] is displayed.

When it reads via Ethernet, [Ethernet] is displayed.

[CF Card]
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Editing a CF Card
The data read can be edited or converted.

Editing/Converting Data
Refer the following list to learn about editable or convertible data.

Folder Name File Name Edit Conversion

BITMAP BMPxxxx.BIN ×  (→*.BMP)

CARD MCMHEAD.BIN ×  (→*.MCD)

MCMxxxx.BIN  (→*.MCD, *.CSV)

DSP DSP0000.BIN ×  (→*.U3/U2)

FONT xxxxx.FTD × ×

HDCOPY HDxxxx.JPG × ×

HDxxxx.BIN ×  (→*.BMP)

JPEG xxxxx.JPG × ×

JPxxxxx.JPG

MEMO MEMxxxx.BIN ×  (→*.BMP)

RECIPE RECxxxx.CSV × ×

SAMPLE SMPxxxx.BIN  (→*.MCD, *.CSV)

SMPxxxx.CSV × ×

SNAP VDxxxxx.JPG × ×

SRAM SRM0000.BIN × ×

WAV WAxxxx.WAV × ×

WEBSERV *.SHT, *.HTML etc. × ×

*

* "Conversion" means editing or modifying the data on the Memory Card

Editor.

How to Edit the Data
The following two kinds of files are editable.

• MCMxxxx.BIN

• SMPxxxx.BIN

 MCMxxxx.BIN

1.  Double-click the "MCMxxxx.BIN" file (in the "CARD" folder).

[CF Card]
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The structure of this window is the same as the [Type: Data] file that is displayed when

[Memory Card] is selected.  Refer to page 20 for the details of the editing method.

 SMPxxxx.BIN

1.  Double-click the "SMPxxxx.BIN" file (in the "SAMPLE" folder).

2.  The data edit window is open as shown below.

2.  The data edit window is open as shown below.

The structure of this window is the same as the [Type: Sampling Buffer] file that is

displayed when [Memory Card] is selected.  Refer to page 14 for the details of the

editing method.

[CF Card]
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How to Convert the Files
The conversion targets are BIN files (the extension [*.BIN]).  There are two conversion

procedures depending on the file format.

 [Put BIN File Back]

File Extension after Conversion

• BMPxxxx.BIN .BMP

• MCMHEAD.BIN .MCD

• DSP0000.BIN .U3, .U2

• HDxxxx.BIN .BMP

• MEMxxxx.BIN .BMP

Follow the steps below.

1.  Select the file to be converted.

2.  Select [Put BIN File Back] from the [File] menu.  Or right-click and select [Put BIN

File Back].

Or right-click

3.  [Save As] dialog is displayed.

Specify the desired file name and click [Save].

4.  The converted file is created in the specified folder.

[CF Card]
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Properties of a BIN File
You can check information about each BIN file before conversion.

Ex.)

BMPxxxx.BIN and MEMxxxx.BIN

The Bitmap image is displayed.

DSP0000.BIN

You can check the file type or version in the [Detail] tab window.

Other BIN Files

In the [General] tab window, the comment that you entered in the [File Comment of

BIN File] field is displayed.  ( [File]  [Write to CF Card] )

[CF Card]



51

 Creating a CSV File

File Extension after Conversion

• MCMxxxx.BIN .CSV

• SMPxxxx.BIN .CSV

Follow the steps below.

1.  Double-click each file and keep it open.

2.  Click [Create CSV File] from the [File] menu.

[Save As] dialog is displayed.

[  Make a File in 256-Column Format]

This setting is effective when the data count in a "MCMxxxx.BIN" file is 256 or

more.

When you save the data in a CSV file and edit it with Excel, only 256 columns

can be displayed.  If the data count is 256 or more, you cannot open the CSV file

with Excel.

If you check this item and save the file, the CSV files will be created

automatically from "(the desired file name) ~1.CSV" with the available number

of columns (= the number of data).

[The data count: 1000] + "Record name" column = 1001 columns

Divided at the 256th column

↓
DATA~1.CSV DATA~2.CSV

DATA~3.CSV

DATA~4.CSV

…

Any file is divided

at the 256th column

[CF Card]
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[  Give a Title]

Using the memory card editor function, each title in a data file can be edited.

Check this box if you save the title as data when saving in a CSV data.

Drag into Excel

If you accept replacing the file, the modified date is stored in the "SAMPLE" folder.

3.  If you save with the desired file name, a CSV file will be created.

Alternate Operating Method (Drag & Drop)
A CSV file or a JPEG file can be confirmed on the Memory Card Editor, but cannot be

displayed or edited.  You can edit or display these files by dragging & dropping into the

other applications.

For example, you can open the "SMP000.CSV" file in the "SAMPLE" folder by

dragging it from the memory card editor and dropping it into Excel directly.

After modifying and saving, if you drag it back to the Memory Card Editor, the

following confirmation message is displayed.

[CF Card]
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Writing to a CF Card
There are three ways to write a data to a CF card.

A)  Batch Transfer

Because all the data in the CF card is read, reading process may take a

long time.

The following method is for batch writing of the data read from a CF card to the CF

card after editing.  Follow the steps below.

1.  Display the list of the folders from the CF card in the Memory Card Editor.

2.  Right-click the [CF] folder, and then click [Transfer].

(Or click the [CF] folder, then click [Transfer] from the [File] menu.)

3.  All the contents of each folder under the [CF] folder are transferred to the CF card

at once.

If you click [Cancel] while the data is being written, the data in the CF

card may be corrupted.  Be sure not to cancel the operation while the

data is being written.

[CF Card]
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B) Individual Transfer
This is the method for writing modified data to the CF card after reading or data

prepared on a PC.  Follow the steps below.

1.  Display the list of the folders from the CF card in the Memory Card Editor.

2.  Right-click the file to be written or the folder which has that file, and then click

[Transfer].  (Or click the file/folder, and then click [Transfer] from the [File] menu.)

3.  The selected file/folder is transferred to the CF card.

For a file prepared on a PC, it is recommended that you drag & drop it into the

appropriate folder in the Memory Card Editor in advance.

[CF Card]
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[File to be Converted]

Click [Refer] and select the file you wish to write to the CF card.  The extensions

of the target files are [*.U3], [*.U2], or [*. MCD].

[*.MCD] File
When selecting a [*.MCD] file in the [Write to CF Card] dialog, the contents of the

[*.MCD] file are written in the CF card format.  The data actually only exists in the

[CARD] folder or the [SAMPLE] folder.

[File Comment of BIN File]

Enter text when annotating the screen data file (DSP0000.BIN: BIN file) written

to the CF card.

[  Use Default Loading]

Check this box when you perform "Auto Uploading of Screen Data."

For more information, refer to in "Chapter 23 CF Card" of the Reference Manual

(Function).

2.  When the setting is complete, click [OK].  The screen data file is saved as

"DSP0000.BIN" (BIN file) in the [DSP] folder of the user folder on the CF card.

At the same time, the specific extension is written to each folder on the CF card

according to the screen data file setting.

C)  Writing from a Screen Data File
Similar to the V-SFT CF Card Manager, by writing from the screen data file of the

UG30/20 to the CF card, the appropriate file (WAV file, JPEG file, or Font file, etc.)

for the screen data file is written automatically.  Follow the steps below.

1.  Select [Write to CF Card] from the [File] menu.

The [Write to CF Card] dialog is displayed.

[CF Card]
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Backing Up a CF Card
It is possible to save the data read from the CF card or the edited files.

1.  Select [Back-up of CF Card] from the [File] menu.

2.  When the [Copy Target Folder] dialog is displayed, click [Refer] and specify the

copy target folder.

Ex. ) When saving in the My Document folder in the C drive:

3.  Click [OK].  The following message is displayed.

4.  Click [OK].  The data on the CF card is copied to the copy target.

When the copy operation is complete, the following message is displayed.

5.  Make sure that the data is copied correctly using Explorer.

[CF Card]
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Copying a CF Card
1.  Click [CF Card Copy] from the [File] menu.

5.  The following message is displayed.  Click [OK].

2.  Specify the CF card drive and click [OK].

3.  The following message is displayed.  Click [OK].

4.  The following message is displayed.  Remove the CF card from your PC and insert

the target CF card.  Click [OK].

6.  When the copy operation is complete, the following message is displayed.

[CF Card]
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[SRAM]

Read/Write data in a SRAM cassette and the built-in SRAM.

Reading from SRAM
1.  Start Memory Card Editor.

2.  When using UG00C-T:

Click [Communication Settings] from the [File] menu.  When the [Communication

Detail] dialog is displayed, specify [Serial Port] and [Baud Rate] of your PC.

[SRAM]

When using Ethernet communication:

1)  Click [Use Ethernet] from the [File] menu.  [Use Ethernet] is checked.

2)  Click [Communication Settings] from the [File] menu.  When [IP Address

Setting] is displayed, specify the IP address of the UG30.

3.  Go to [File], [SRAM], and then click [Read from the Sram Memory].

Reading data process is started.
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[SRAM]

4.  When reading is complete, the window shown below is displayed.

Editing SRAM

[MCard]
Click the [MCard] folder in the tree display in the left window.

Each file of the memory card emulation is displayed in the right window as shown

below.
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[SRAM]

If you double-click each file, the contents of each file are displayed similar to the case

where [Memory Card] is selected.  The editing method is the same as the method

described for [Memory Card].  For more information, refer to page 14.

 Confirming Properties

It is possible to confirm the setting items of the memory card emulation area.

Right-click each file in the [MCard] folder, and then click [Property].  The [Display

Memory Card Information] dialog is displayed as shown below.

All 16 files in the [MCard] folder can be checked.
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[SRAM]

 Saving to a MCD File

It is possible to save the memory card emulation area as a [*.MCD] file.

Click [Save As] in the [File] menu while the desired file in the [MCard] folder is open.

Or right-click each file, and then click [Convert].

or

The [Save As] dialog is displayed as shown below.  Specify the desired file name and

click [Save].

After you save the MCD file, it is opened as memory card data, not as SRAM data.

Open the file by clicking [File], [Memory Card], and then [Open], or clicking the [Open]

icon.
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[Memo]
Click the [Memo] folder in the tree display in the left window.

Each of the memo pad data (No. 0~7) is displayed in the right window as shown below.

[SRAM]

 Confirming Properties

The contents of the memo pad can be checked.

Right-click each file in the [Memo] folder, and then click [Property].  The following

dialog is displayed.

 Saving to a BMP File

It is possible to save the memo pad data as a [*.BMP] file.

Right-click each file in the [Memo] folder, and then click [Convert].

The [Save As] dialog is displayed as shown below.  Specify the desired file name and

click [Save].
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[SRAM]

[$L] / [$LD]
Double-click the [$L] / [$LD] folder in the tree display in the left window.  The

following window is displayed respectively.

 Editing Data

It is possible to enter/modify the value in each address.

Click each cell to select.  The value is modified by entering a numeric value with the

keyboard.

If you enter a value which does not correspond to a format (Ex: Write

[HEX] to [DEC]), the data is ignored.

 Data Format Batch Settings

Modify the display formats in each address all at once.

You cannot set the display format for each cell individually.

Click [All Data Format Settings] from the [Edit] menu.  The [Data Format] dialog is

displayed.
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[SRAM]

If you click [One Line Format] from the [View] menu again, the check mark is

removed.  The window is changed back to the original 10-column display.

 Saving to a CSV File

It is possible to save the contents of $L and $LD to a CSV file.  Follow the steps below.

1.  Click [Create CSV file] from the [File] menu.

The [CSV] dialog is displayed.

Specify the type or the decimal point.  When you click [OK], all the cells are displayed

in the format you set.

 Display Switching (10-column / 1-column)

It is possible to switch from 10-column display to 1-column display.

Click [One Line Format] from the [View] menu.  The window is changed to the single

column display.

2.  When you save with the desired file name, a CSV file will be created.
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[SRAM]

 Reading from a CSV File

It is possible to read the contents of a CSV file.  Follow the steps below.

1.  Click [Create CSV File] from the [File] menu.

The [CSV] dialog is displayed.

2.  Select the file to be read and click [Open].  The contents of the CSV file are read.

Writing to SRAM
While displaying the [SRAM Manager] window, with the files in each folder closed,

click [Transfer to Display] from the [File] menu.

Write data.

If you click [Cancel] while the data is being written, the data in the CF

card may be corrupted.  Be sure not to cancel the operation while the

data is being written.
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Saving SRAM
It is possible to save the read SRAM data as a [*.RAM] file.

Click [Save] from the [File] menu.  The message "Save [Untitled]?" is displayed.

[SRAM]

When you click [Yes], the [Save As] dialog is displayed.  Specify the desired file name

and click [Save].  It is saved as a RAM file.

When you open the file, you can go to [File], [SRAM], and then click [Open].
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